I've seen a few post similar to this, but I still have the network unreachable.

How do I bring up my wireless network at boot?

"Waiting for network configuration" adding 3 to 5 minutes to boot time

I can't reinstall because I have mysql databases in the system.

I don't know what any other thing I can do.



#The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet dhcp
wpa-ssid xxxxxxx
wpa-psk xxxxxxxx
  • Your network configuration is broken. You can start with attaching the output of cat /etc/network/interfaces and a few screenshot of the interesting parts of network-manager. But it will be a long thread... – Avio May 31 '12 at 19:44
  • My case is exactly the one of the first link in the post, but in my case the solution provided doesn't work. I have not installed a graphical environment so I can not post any screenshots. – Antonio Sánchez Jun 1 '12 at 7:58
  • 2
    I will finally give up. I have recovered databases and will reinstall the server. I think this time I will use Debian. With the system just installed I also had this problem but at least I had access to network after boot or even just after rebooting. Now I have no network. I have seem a few reports in launchpad still in 12.04. Not a good thing, this is a server and will move to Debian or Centos. Thanks anyway. – Antonio Sánchez Jun 3 '12 at 18:14
  • 1
    I don't think that a problem like this can provide a good reason to change distribution. One should choose its distro based upon its philosophy, its community, its packaging system, not based upon a bug on boot. I also had a machine with this problem: I first solved via a startup script, but now, after applying this ugly and unclean solution everything works like a charm. – Avio Jun 3 '12 at 20:38
  • Well, it's about confidence. I'm not a expert in Linux but specially in a server I expect not to suffer this type of incidences. This is a bug in basic functionality and should work out of the box. In this case you can not imagine how harmful has this issue been, it's been really painful. Now it is not about fixing the bug but instead I just question: what will be the next one? As said above it is a question of confidence. I love Ubuntu for desktop but I will think it twice when talking about servers. Thank you very much indeed. – Antonio Sánchez Jun 4 '12 at 7:16

I suspect that (sadly) the second thread you posted has the answer. It seems now that the /etc/network/interfaces file contains the interfaces that have to be brought up necessarily by the system, while network-manager is in charge of "non system-critical" interfaces.

So the "best practice" now seems to be to leave empty the /etc/network/interfaces file and set your interfaces inside network-manager.

However, if for any reason you don't like this approach (e.g. I don't like it) there could be another not-so-clean solution. You could edit your /etc/init/failsafe.conf file and comment-out the two sleep of 40 and 59 seconds. This will make your Ubuntu boot faster, but you can't take it for granted that you will have your network interfaces up at the end of the boot process.

  • As commented in main post I give up. Thank you. – Antonio Sánchez Jun 3 '12 at 18:15

Yes the same happened to me when I installed Ubuntu 12.04.1 Server + no-install-recommends ubuntu-desktop on two Lenovo IBM Thinkpads. I also got “waiting for network configuration” and network down messages and I was totally unable to get the wireless adaptor working.

However the fix for me was to make the /etc/network/interfaces file as simple as possible. I changed it to only use three lines:

#The loopback network interface
auto lo
iface lo inet loopback

Ubuntu then starts up really quickly with no delays. The eth0 adapter starts automatically and I then configure the wlan0 wireless network via Network Connections.


P.S. Unity is brilliant for quick keyboard navigation around a GUI screen. Canonical have really raised the bar.


Refresh your MAC address using Virtual Box machine settings and remove the kernel’s networking interface rules file so that it can be regenerated:

sudo rm -f /etc/udev/rules.d/70-persistent-net.rules sudo reboot

It will work for your clone VM.

  • This answer worked for me – Vitor Mazuco May 27 '15 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.