3

I installed my own kernel with my own kernel config. This broke Firefox. I added squashfs to the kernel config, hoping it would fix snap, which didn't help. I tried to reinstall Firefox via apt and snap, and also tried to do that with the Ubuntu kernel. No progress. It's just totally broken.

$ firefox
(... not installed ...)
Please install with:

snap install firefox

$ snap install firefox
snap "firefox" is already installed

$ snap remove firefox
error: cannot perform the following tasks:
-- Remove data for snap "firefox" (unlinkat ... read-only file system)

Chromium broke too, but I somehow managed to make it work by reinstalling it.

How to fix firefox? I'm not gonna reinstall the distro.

Second question: How to make snap work with a custom kernel? Which kernel modules do I need?

Third question: Why was such a fragile thing like snap put into Ubuntu and why are web browsers dependent on it? You do know that if it breaks, people won't have any access to the internet other than elinks? How will they upload logs and file bug reports without a web browser?

1
  • It's not firefox that needs fixing, but your kernel. Reboot back to a stock kernel and debug from there. You could diff your confg vs the stock kernel config, and could enable snapd debugging to get more information about why the snap won't load. You could also grab the tarball of firefox if you need to launch the browser under your own kernel in the meantime.
    – popey
    Dec 23, 2022 at 9:47

1 Answer 1

2

You may try:

$ snap enable firefox

and run

$ snap remove --purge firefox

or

$ snap-store

find firefox in 'installed' tab and uninstall it

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .