1

After following my own detailed manual installation instructions here for an NVIDIA video driver, my laptop no longer shows anything on the built-in monitor! The "Display" settings also indicate only one monitor is present. After logging in, if I unplug my external monitor, my laptop monitor still remains blank and I cannot see anything.

I know the built-in monitor is working, because the BIOS/UEFI flash screen still displays on it before getting to the Ubuntu login screen.

How do I get the graphics driver to work with the internal display again as well?

Is it because I installed the 32-bit compatibility drivers? Is the problem I chose "Yes" to the X Window thing in my instructions? Is it because I had the external monitor plugged in while I ran the installer?

The driver installation README is here: http://us.download.nvidia.com/XFree86/Linux-x86_64/525.60.11/README/index.html

1 Answer 1

1

Solved:

1. Enable "Discrete Graphics" in your BIOS/UEFI

First off, the default graphics setting for my laptop was "Hybrid Graphics", which is incompatible with the NVIDIA drivers:

From my answer here:

Your BIOS/UEFI probably supports (it should) setting your graphics mode between "Hybrid Graphics" and "Discrete Graphics". NVIDIA says you must use "Discrete Graphics" mode to be compatible with their driver. However, if you set your mode to "Hybrid Graphics", it does make your brightness buttons work again because then your internal graphics card built into the CPU will handle that, but then again your NVIDIA graphics driver will also be glitchy and you may notice problems, and NVIDIA says to use "Discrete" mode.

So, boot into your BIOS/UEFI and change your settings to "Discrete Graphics" mode:

enter image description here

The meaning my UEFI tells me is (emphasis added):

  • Discrete Graphics mode will achieve higher graphics performance.
  • Hybrid Graphics mode runs as Integrated Graphics mode to achieve longer battery life, and Discrete Graphics is enabled on demand.

That tells me that the internal integrated graphics card built into the CPU chip is more-efficient, and the NVIDIA card is the external "Discrete Graphics" card.

enter image description here

NVIDIA says to use "Discrete Graphics" only, however, under the "Additional Information" tab of their download links, such as here for 515.86.01, for instance: https://www.nvidia.com/download/driverResults.aspx/194662/en-us/ (emphasis added):

Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available.

2. Ensure you don't have "Single Display" accidentally selected

My display brightness function buttons are Fn + F5 and Fn + F6. My monitor display settings button is Fn + F7, right next to those. So, it's possible I bumped my display function buttons while setting my brightness, accidentally setting my display mode to "Single Display"--External Only! That would obviously turn off my laptop's built-in monitor. So, go to your system Settings --> Displays and ensure you have "Join Displays" or "Mirror" selected:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .