I have a pptd server installed on a remote BareMetal server I have followed the tutorial here to the dot:

However I get

MGR: dropped slow initial connection

I have tried everything I can think of

  1. Turned off UFW completely
  2. Tried to enable/disable all combinations of encryption
  3. I have done local port forwarding where I pptp to my localhost 1723 and then that is forwarded by ssh to on the remote
  4. I used a tested proxy in between

I have copied the setting line by line and produced the same server locally at my home and it works with no problems at all.

I tried toggling pptp forwarding at my router it had no effect

the issue persists no matter where from I try to connect to it, including locally from the machine itself. Issue is I have no idea what this is at all, btw,looking at c Code does not help me because I am not that skilled with reading sources of software such as PPTpd can anyone please help me, I am literally going insane

1 Answer 1


In some country like China and Iran and maybe Russia, there is a thing called Great Firewall that they spend good money to develop and maintain, it fillers or Block or Disrupt any VPN protocol base on the Protocol headers and behaviors, so most likely you are behind one of them!

  • indeed I am behind one, how can I go about attempting to get around it?
    – Max
    Dec 31, 2022 at 7:42
  • You should use Tunneling Protocols in addition to VPN protocols, Stunnel with OpenVpn usually works , or Proxying instead of VPNing is a good solution..
    – malloc
    Jan 11 at 12:37
  • I have been using ssh dynamic tunneling, it works pretty fine from Iran, except I cannot get it working on my Android (JuiceSSH is a good app but it is monetary :/ ). So I am trying to find a better alternative. First try with PPTP failed, as discussed in the above answer. Jul 8 at 19:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .