Running the latest 22.04 on a Lenovo Legion 5.

Yesterday applied a regular update, including to the kernel. Afterwards was presented with another update. Said yes, but it went into an update loop between two sets of updates. I didn't write down what they were.

Booted today to the default 5.15.0-1025-oracle and wired network didn't appear, nor was there anything in settings even to configure a wired or wifi connection. No network at all. The other kernels in grub are: 5.15.0-1021-intel-iotg: tried, same outcome; 5.15.0-1-56-lowlatency: running on this now; 5.15.0-1-56 generic: haven't tried

Can I fix 5.15.0-1025-oracle, or should I stay with 5.15.0-1-56-lowlatency and take updates again from there. If so, will 1025 get deleted from grub?

Thanks, Ken

  • Same problem here with update of the Linux kernel from 5.15.0-53 to 5.15.0-56. The current answers below didn't help, as there is nothing related to "oracle" or anything else mentioned below installed. (current fix: boot with 5.15.0-53)
    – feeela
    Jan 6 at 16:48

2 Answers 2


Something similar happened to me. Looking at /var/log/apt/history.log , it seems that the oracle, lowlatency, and intel-iotg kernels were installed automatically.

Start-Date: 2022-12-02  20:02:42
Commandline: packagekit role='update-packages'
Requested-By: angel (1000)
Install: linux-objects-nvidia-510-5.15.0-1021-intel-iotg:amd64 (5.15.0-1021.26+1, automatic), linux-signatures-nvidia-5.15.0-1021-intel-iotg:amd64 (5.15.0-1021.26+1, automatic), linux-objects-nvidia-510-5.15.0-1025-oracle:amd64 (5.15.0-1025.31+1, automatic), linux-signatures-nvidia-5.15.0-1025-oracle:amd64 (5.15.0-1025.31+1, automatic), linux-modules-5.15.0-1021-intel-iotg:amd64 (5.15.0-1021.26, automatic), linux-modules-5.15.0-56-lowlatency:amd64 (5.15.0-56.62, automatic), linux-image-5.15.0-1021-intel-iotg:amd64 (5.15.0-1021.26, automatic), linux-image-5.15.0-56-lowlatency:amd64 (5.15.0-56.62, automatic), linux-signatures-nvidia-5.15.0-56-lowlatency:amd64 (5.15.0-56.62+1, automatic), linux-image-5.15.0-1025-oracle:amd64 (5.15.0-1025.31, automatic), linux-modules-5.15.0-1025-oracle:amd64 (5.15.0-1025.31, automatic), linux-objects-nvidia-510-5.15.0-56-lowlatency:amd64 (5.15.0-56.62+1, automatic)
Upgrade: libglib2.0-dev-bin:amd64 (2.72.1-1, 2.72.4-0ubuntu1), libglib2.0-bin:amd64 (2.72.1-1, 2.72.4-0ubuntu1), libglib2.0-dev:i386 (2.72.1-1, 2.72.4-0ubuntu1), libglib2.0-data:amd64 (2.72.1-1, 2.72.4-0ubuntu1), libruby3.0:amd64 (3.0.2-7ubuntu2.1, 3.0.2-7ubuntu2.2), ruby3.0:amd64 (3.0.2-7ubuntu2.1, 3.0.2-7ubuntu2.2), libglib2.0-0:amd64 (2.72.1-1, 2.72.4-0ubuntu1), libglib2.0-0:i386 (2.72.1-1, 2.72.4-0ubuntu1)
End-Date: 2022-12-02  20:03:20

I solved this issue by uninstalling them:

sudo apt remove linux-image-5.15.0-1025-oracle linux-modules-5.15.0-1025-oracle linux-modules-5.15.0-1021-intel-iotg linux-modules-5.15.0-56-lowlatency 

The grub configuration was correctly regenerated with the generic kernels.

  • Thanks for the info. This doesn't appear to be the case for me, but I will investigate further tonight. Dec 6, 2022 at 0:33
  • Actually, removing the additional kernel's is what worked, though I had to update grub manually. Jan 12 at 7:01

Elaborating on the answer by @Angel. I had to combine this solution with a regeneration of the netplan settings.

First boot into ubuntu with the 'generic' kernel, not the 'oracle' kernel.

Then remove all relevant kernels etc, which in my case was (comparable to Angel):

sudo apt remove linux-image-5.15.0-1025-oracle linux-objects-nvidia-525-5.15.0-1025-oracle linux-signatures-nvidia-5.15.0-1025-oracle linux-modules-5.15.0-1025-oracle

Then the second part (credits to linuxconfig.org/ubuntu-22-04-network-configuration):

Then check your network interface

sudo lshw -C network

and check your output for this part:

logical name: enp42s0 (note that the enp42s0 may be different, e.g. en01).

Then I edited the netplan file which was /etc/netplan/....yaml. (e.g. sudo nano /etc/netplan/....yaml (or whichever editor you prefer).

  version: 2
  renderer: networkd
      dhcp4: true
      dhcp6: true
      optional: true

For wifi adaptors this is somewhat more elaborate, this may be found by looking into for netplan. e.g. the linuxconfig link I put above.


sudo netplan regenerate
sudo netplan apply

and reboot.

That worked , but I see that in my case, other devices are also 'broken' (audio, e.g.) so this will only pertain to the network part and my audio that didn't work before either, got reactivated as well.

Good luck!

  • Thanks, as I said above, just deleting the unwanted kernels and updating grub fixed things for me. I didn't have to regenerate netplan. I was on 56-generic, but recently took the offered 57-generic update and I'm back on the right path. Jan 12 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.