The issue I've is that when I connect via modem through gnome-ppp the Network Manager Applet don't detect a connection and don't let me use the configured VPNs via its interface.

How Can I manually activate the Network Manager Applet?

What I need is to enable the Network Manager apple in order to use the "VPN Connection" section of the GUI.

When I don't have an ethernet cable connected and I connect through a modem the Network Manager applet doesn't enables itself, it is like if don't recognizes the ppp0 interface. My question is: there is a way to force the Network Manager GUI indicator to make it "alive"/"up"/"enabled" in order to use the "VPN Connections"section?

Thanks in advance.

  • What do you mean with manually? nm-applet (NetworkManager) is not intended for command-line nteraction but instead runs in the GNOME desktop environment. – pl1nk May 31 '12 at 1:08
  • @pl1nk: Hi! Thanks for take time to answer. I updated the post. – diosney Jun 2 '12 at 3:20

Run nm-applet. Make sure you have a panel running. If you need command-line interaction capability, check out wicd and wicd-curses.

  • Thanks for taking time to answer. I executed nm-applet and it showed up two Network Manager indicators instead of "activate it". – diosney Jun 2 '12 at 3:13

For testing run as root nm-applet and check if ppp0 is activated.

In any case check files:



And alter them according to your needs. This post may be of help to you.


Finally I got a solution for my own but it is a tricky one and it isn't useful for the people that don't have a Wireless adaptor.

The steps what I did were:

  1. Enable the Wireless adaptor of my laptop by turning on the hardware switch.
  2. Create a new ad-hoc connection.
  3. Connect to the local wireless ad-hoc connection.
  4. The Network-Manager applet brings to live allowing us to select the VPN to connect through.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.