So I have Ubuntu 22.04.1 running on a fairly new desktop (specs below). Since installation there always have been some minor freezes here and there, but nothing that couldn't be fixed by rebooting or reinstalling the Nvidia driver. The issue has, however, escalated a few days ago when I shut it down after it had been running smoothly for over a week. Currently it has become next to unusable; the desktop would freeze randomly, sometimes immediately after reboot, other times a few hours later. When this happens, the system goes completely unresponsive.

It should be noted that before shutting down, which I did due to background processes taking up too much RAM and swap, I had run swapoff, but interrupted it before it could finish. I'm not sure whether this could have caused what I'm experiencing right now.

Things I've tried so far

  • I read through /var/log/syslog several times after this happens, nothing special is spotted since every time it looks a bit different and no apparent error message is shown.

  • The SysRq keys never worked.

  • I tried reinstalling Ubuntu 22.04.1 on an empty SSD (after nvme format) and an HDD, neither helped.

  • The smartctl and nvme utilities don't report any severe disk errors, apart from 3 UNC errors on the HDD.

  • Disabling iommu didn't affect anything.

  • memtester with 30 GB RAM tested didn't report any errors.

  • When the freezing happens, free -m, sensors, top, or nvidia-smi (when I have driver installed) don't show any abnormal activities (temperatures are low etc). The issue persists even with only the default GPU driver (nouveau).

  • At first booting from a live USB was relatively stable, but now the same thing happens as well. I have tried 22.04.1 and 20.04.5 with this one.

  • Removing the graphics card altogether doesn't change anything.

  • This may be related, after removing the CPU cooler I found out that a plastic film that should have been removed was in between the cooler and the processor (the PC was assembled by a local hardware store), so basically the CPU had been running for almost a year without proper cooling. Before this, the CPU temperature was constantly at ~90 C as reported in the BIOS. After its removal, the temperature dropped significantly (to ~40 C), yet things regarding the freezing didn't seem to have changed.


Motherboard: ASUS TUF Gaming H670-Pro Wifi D4

Processor: Intel i9-12900K

GPU: RTX-3070Ti (manufacturer Zotac)

RAM: 16GB x 2 DDR4 2667 MHz (XPG)


  • WD Black SN750 SE 1TB SSD
  • Seagate Barracuda 2TB HDD

I believe this is a hardware issue, but I'm not sure what the next step of diagnosing the problem might be. Any ideas or comments are appreciated.

  • I am experiencing this is too. It's really frustrating, I don't know what to do, my laptop just freezes and nothing workes except I switch it off through the power button. I use a MacBook pro 2012 and Ubuntu 22.04 installed. Aug 2 at 12:30

1 Answer 1


Regarding the hardware issue, I just looked it up and the max temperature for your CPU is around 100°C. So there theoretically shouldn't have been physical damage, but considering it has been at a constant 90°C for a year of using it - I wouldn't disregard the possibility of hardware damage.

After all you tried, my only guess would be that the problem is Wayland (if you're using it). So if you are using Wayland, switch to XOrg by selecting your user at the login screen and clicking the gear icon in the bottom right. Select XOrg.

Also, how long are the freezes? If they're short try enabling Full composition pipeline in the Nvidia settings. I believe it's located in "Display" or something similar. Go to advanced options. There, enable the full composition pipeline and save to the X Config file (for this you will need to run the app as sudo from the terminal). This hasn't really ever helped me, but I heard it should help with screentearing and minor freezes so you should give it a shot if the freezes aren't severe.

  • I actually already have WaylandEnable=false in /etc/gdm3/custom.conf
    – fierslug
    Dec 2, 2022 at 7:12
  • 1
    The freezes usually are forever, at least longer than any duration I have waited
    – fierslug
    Dec 2, 2022 at 7:13
  • i have same problema here... after some time it returns to 'normal' but i always kill everithing that uses chrome so (vstudo code and chrome itself) I use X11 to because of teams app that is very trash on wayland... Mar 2 at 18:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .