I cannot get into Windows Vista .... I was working in Vista and then I restarted booted up Ubuntu and when I finished in Ubuntu I restarted this time in Vista and all I get is the microsoft box with the vertical stripes running interminably. I ran sudo update-grub this is the result of that command:

generating grub.cfg
found linux image: /boot/vmlinuz-3.2.0-24-generic
found initrd image: /boot/iniytd.img-3.2.0-24-generic
found linux image: /boot/vmlinuz-3.0.0-19-generic
found linitrd image: /boot/initrd.img-3.0.0-19-generic
found windows recovery environment (loader) on /dev/sda1
skipping windows recovery environment (loader) on Wubi system
found windows vista (loader) on /dev/sda2
skipping windows vista (loader) on wubi system

I do have a backup of my Windows environment on an external hard drive and I can get to it through ubuntu but I am not sure if I can restore Windows Vista from Ubuntu or even if I need to.

Thanks for any help.

  • By the way, did you install booting a CD/USB or using the WUBI installer while running Windows? – Andrew Wonnacott May 30 '12 at 22:00
  • I used the Wubi installer – railguage48 May 30 '12 at 22:26
  • Ah, that means your install assumes that you boot Vista first. When you start up, do you get a choice screen with a box with a list (GRUB) or a block of text, options, and another block of text, in a larger font (NTLDR)? – Andrew Wonnacott Jun 1 '12 at 0:44

Install grub-customizer (from a PPA on launchpad) and enable the windows image

You asked for details, here you go:

Open up terminal - the commands add the extra line to your sources to allow you to install this new piece of software and get updates for it, the second installs it, then it should show up in the application launcher - if it doesn't, just run sudo grub-customizer after the last one.

sudo apt-add-repository ppa:danielrichter2007/grub-customizer

sudo apt-get install grub-customizer

After each command, you may have to enter your password - this is because you have to confirm this way to add or remove software. It will prompt in the terminal, not by covering your screen with a message, so check for it.

  • @Andrew...thanks for your help ... do you think you could expand on your answer .... I do not have the knowledge to understand the advice you gave ... thanks again. .... just found the answer ... thanks again. – railguage48 May 30 '12 at 21:54
  • If I solved your problem, please mark my answer as 'correct' by clicking the check mark. Also, I'd love an upvote if you feel I answered it well, not just correctly! :P – Andrew Wonnacott May 30 '12 at 22:22
  • I ran the grub-customizer and now I have a terminal with my prompt waiting ... do I have to do something here? Thanks for your patience. – railguage48 May 30 '12 at 22:23
  • if grub-customizer is installed, it should open a window. the way terminal works, you can run one program at a time - if launched from the launcher, it shouldn't be giving you a terminal. Try closing the terminal, opening a new one, and running sudo -v, typing your password, then sudo grub-customizer; this should bring it up if installed – Andrew Wonnacott Jun 1 '12 at 0:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.