2

When I try to print, for some reason all the printers I previously had installed have disappeared.

I pulled up the "Printing" dialog, and I see that localhost is "Not connected," but when I try to connect, it fails. I have looked this up in various places, but the only two suggestions I've found have not worked. The first was to put apparmor into a less strict mode, and the second was to reset CUPS. I've done both of those things, and to no avail.

I just want to print again!

  • How are the printers connected? Via network, or via usb? – txwikinger Aug 6 '10 at 18:34
  • They're networked, but it seems like CUPS just isn't working, so I'm not sure it would matter. – mlissner Aug 6 '10 at 18:40
2

What do you think where 'localhost' aka 127.0.0.1 goes? Thats your network-card and if there is a printer connected it will have annother ip-address. So printing on 127.0.0.1 will not work. Try install a new printer in your printing dialog, if it will be identified thats ok, if not post some more information about your network.

| improve this answer | |
  • The printer was installed properly before, but at this point, I can't even add new printers, because it seems like CUPS must not be running (when I try, the option is grayed out). I haven't changed anything about my network or CUPS to my knowledge? – mlissner Aug 6 '10 at 22:15
0

How funny! I just was looking for a permanent solution to this problem.

Here is what will fix it when it happens.

Open Terminal: type: sudo /etc/init.d/cups restart hit enter enter your password and the problem should be solved.

My issue is that it is not a permanent fix. I have to keep repeating it anytime my computer is restarted. This seems to be a new issue with 10.04.

I would love to hear a permanent solution.

| improve this answer | |
  • Yeah, as I mentioned above, that doesn't do anything for me - temporary or permanent. – mlissner Aug 6 '10 at 18:57
  • @Tom You can, If you want make a script that will run on boot. That would be a sorta permanent solution. – megubyte Aug 6 '10 at 19:08
0

/var/run/cups/cups.sock

check this is the path to your cups server.

11.10:

Click ubuntu logo and then search printing. Hover near the top to get server and click this then click edit and check the path above is entered

before unity:

printing preferences ( think it's system on the menu at the top ) basically the window with all your printers in. Click server and edit and then check the path at the top is entered.

Don't forget to logout and log back in if you've changed the path.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.