I've just upgraded Ubuntu from 22.04 to 22.10 some days ago. I'm experimenting some troubles by watching any online video stream and any mp4 videos saved on my PC. Basically they don't flow. To make them flow I should press the play button again and again and again and everytime I press it,only a small portion of the video go on. In addition,no audio output device work on my PC. After having exposed the problem in several places,I've found the reason because a nice reddit user gave to me a suggestion. He says that the cause of the problem is pipewire-media-session and that I should change it with wireplumber. This is what I tried to do. I've got the proof and the counter-proof that his suggestion is good. The commands that I should issue to fix the problems are the following :

$ systemctl --user unmask pulseaudio

$ systemctl --user --now disable pipewire-media-session.service

$ systemctl --user --now disable pipewire pipewire-pulse

$ systemctl --user --now enable pulseaudio.service pulseaudio.socket

sudo apt remove pipewire-audio-client-libraries pipewire

I suppose that those commands enable pulseaudio and remove pipewire. Infact the problems that I've explained above, go away. Instead,when I try to enable pipewire + wireplumber issuing the following commands the problems come back :

$ sudo apt install libldacbt-{abr,enc}2

$ sudo apt install libspa-0.2-bluetooth pipewire-audio-client-libraries pipewire-media-session- wireplumber

$ systemctl --user --now enable wireplumber.service

$ sudo cp /usr/share/doc/pipewire/examples/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/

$ sudo apt remove pulseaudio-module-bluetooth

Its now clear that some elements of pipewire does not work correctly on Ubuntu 22.10,in some situation. I could still use PulseAudio,but I want to understand how to fix the problems pipewire is affected by. Someone can help me ? thanks. 0 commenti

  • First it is worth to check, that pipewire can better work on your hardware. Try other Ubuntu flavours with pipewire preinstalled - Ubuntu Mate or Ubuntu Budgie. Nov 20, 2022 at 20:40
  • thanks for the suggestion. I've booted ubuntu budgie as virtual machine within bhyve and sound worked. So,my hardware is compatible with pipewire. At this point pipewire could not work in ubuntu 22.10 because some bug. (take in consideration that it works with ubuntu 22.04)
    – Marietto
    Nov 21, 2022 at 0:01

1 Answer 1


Have same problem with Debian 12 and I had not enough time for further checks. As workaround a restart of wireplumber helped me first.

systemctl --user restart wireplumber.service

Than I removed wireplumber, but I'm not sure what effects this has. Now sound output is working again on my notebook without described problems.

sudo apt remove wireplumber libwireplumber-0.4-0 # it's the same command in Ubuntu 22.04 and 21.10

Later I installed wireplumber again and all is working. Before deinstallation I did not see all audio devices with status command, now it looks better.

sudo apt install wireplumber
wpctl status #check
  • Thanks. Reinstalling wireplumber worked. Previously, a video would start playing, audio continued on and the video froze. Eventually it would loop. Very strange. Jun 1 at 23:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .