My Aspire One netbook is now a notbook.

It's an AOA-110 that has worked fine forever and a day (currently with Maverick UNR, fully updated). Last night, I was ereading and went to go online to look something up. I notice that not only am I not connected, but my AP is not even visible.

Okay. Research time.

I find out about RFKILL. It is showing a hard block on the ATH5K device. The switch is NOT flipped.

Among other things, I have tried remapping the switch and the steps listed in #49 here.

Unfortunately, between this, the current UDEV worker error, the fullscreen Flash video error, and apparently narrowly avoiding the devkit SSD issue, and the perennial lack of progress on Launchpad (as well as two weird errors on two Wubi installs done to make converts), I am losing all faith in Ubuntu.

In addition, even when a hard block seems to be missing, neither Network Manager nor Wicd seem to see the AP I know is there and in range. iwlist scan shows no results, and iwconfig shows the WLAN0 interface.

Enough discussing, on to questioning.

How can I fix this? Secondly, any ideas on why this is happening?

I am desperately fighting a complete reinstall. Any help out there?

  • it appears to me that most of the "problems" you are referencing come back to buggy firmware on newer netbooks. mine is older, but continues to work just fine. – RobotHumans Nov 22 '10 at 15:05
  • I doubt you might consider a two year old netbook newer, but okay... – Samizdata Nov 23 '10 at 1:25
  • 1
    The OP says this is working now and wants this closed. As far as I can tell, no answer that is known to work was posted. So we should consider closing this as too localized. – Eliah Kagan Sep 3 '12 at 21:49

Firstly, ensure you're using the most current bios. Secondly, I'm presuming you've set rfkill to soft-unblock the device. Thirdly, I'm presuming you've purged hal from your system (which would be the default state if you did a fresh install of Lucid or Maverick). Fourthly, have you filed a bug against the linux source package with ubuntu-bug linux ?

| improve this answer | |
  • Weird. Let the battery full drain, charged it back up, and no problems. I try to do that every so often to keep the battery life high. – Samizdata Nov 23 '10 at 1:24
  • I haven't had this problem in a LONG time. of course I have disabled sleep/hibernate completely as this was a bone of contention for a long time and disabling was acceptable for me. in my opinion, for me it wasn't random. it was a resume from suspend/hibernate/low power problem. i accept a certain level of buggy in exchange for free and open. – RobotHumans Nov 29 '10 at 21:01
  • @Samizdata Actually, this trick with battery drain does not work and can sometimes even make things worse. – nanofarad Sep 3 '12 at 21:58

It still seems to be working, so I will close this and let people get on with the more urgent questions.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.