This is with a new install of Ubuntu Studio 22.04

It has always been a challenge to get Firewire multichannel interfaces working in Linux using qjackctl, and this was the first time of trying with the new install. I plugged it in and started the computer. The interface started up and connected without using qjackctl. It appeared as an option in the list of system audio-out ports.

All attempts to run qjackctl failed. I ran Reaper (a DAW) and saw all of the input and output ports appear as I am used to, almost. I played a track and the sound appeared in the headphone ports 5&6. And 7&8. And 1&2. I needed to disable remixing by changing a line in ~/.conf/pulse/daemon.conf to,

remixing-use-all-sink-channels = no

I needed to stop pulse repeatedly trying to add the Saffire as a system audio output and input port because it was continually failing to set up the system audio. All attempts to kill autospawn, and pulseaudio, itself (yes, I tried that as well!) failed.

Ubuntu Studio was connecting the Saffire as a system Stereo In and Stereo Out interface. Anything routed to Ports 1&2 came out of the Line Out socket. I tried Studio Controls and disabled the pulse bridge and removed the Saffire options from the system Mic and Output options, but no change in Reaper. I configged Studio Controls to use FFADO with no change. I found a way to start the jack daemon in terminal and use the qjackctl features. All the correct auto-Connections were made, but I could only get an output on ports 1&2 and this came via the headphone port on Outputs 5&6.

Then I noticed that the port designations in the Reaper Routing were scrambled. In earlier versions of US and in Windows, the inputs appeared as eight mono ports: Saffire Pro Line 1&2 1, Saffire Pro Line 1&2 2. Saffire Pro Line 3&4 1, Saffire Pro Line 3&4 2... HD Audio Line Input 1, HD Audio Line Input 2 and then presented as stereo ports: Saffire Pro Line 1&2 1 (Stereo M/C), Saffire Pro Line 1&2 2 (Stereo M/C) Pro Line 3&4 1 (Stereo M/C)... HD Audio Line (Stereo).

I think that these are derived from the output of ffado-test Discover.

With the current version of US, they looked superficially the same, but there was a sequence of eight firewire_pcm00130e0100060f3e_L, followed by two firewire_pcm00130e0100060f3e_S, followed by eight firewire_pcm00130e0100060f3e_L (Stereo M/C) and then one firewire_pcm00130e0100060f3e_S (Stereo M/C).

It was a similar situation for the output ports. I'm assuming that Reaper is trying to make sense of the system allocating a stereo pair for output and input to an audio interface that it knows has 10 inputs and 10 outputs, but that is just a guess.

It seems that even with selecting the FFADO driver rather than alsa, removing the pulse bridge ports from Studio Controls and getting the Saffire out of the system volume port list, alsa is not presenting the 10 x 10 port interface correctly.

From my surfing, it seems that jack runs with the ports enumerated by alsa, but why this latest version of Ubuntu Studio is making such a pig's ear of it, I don't know.

I tried a Focusrite Scarlet 16 x 16 USB interface and the situation is better. I can route the sound to the headphone ports rather than ports 1&2. However, the designations in Reaper are scrambled and port 5&6 seems to be connected to the DAW sockets for 8&9. Again, there were the correct number of input and output ports. The various qjackctl panels (Graph, Connexions and Patchbay) showed all the correct sockets, connections and patches, but something interferes between qjackctl and the DAW.

I tried with Ubuntu Studio 22.04 Live with exactly the same results. Out of the box, Ubuntu Studio seems fine for a firewire or USB external stereo audio interface, but cannot cope with multichannel, no matter what I tweak.

Any thoughts?

  • So, that's a lot to digest and I have no expertise in audio matter to really understand everything… But one thing I noticed is that you had problems with pulseaudio and jack combination. And then, I presume, you got some problems because of that…? So, what you can try here is install PipeWire, which is supposed to be a modern replacement to PulseAudio and Jack, and provides both APIs simultaneously. Though, don't use PW from the repos, it will be old. Add a PPA instead before installing.
    – Hi-Angel
    Nov 9, 2022 at 19:44
  • Regarding stopping PulseAudio service: this command seem to have worked for me: systemctl --user stop pulseaudio.socket pulseaudio. And this one is to start PipeWire: systemctl --user start pipewire{,.socket,-pulse,-media-session} pipewire-pulse.socket. PW is provided with either wireplumber of the media-session. It seems the PPA for whatever reason has only the latter.
    – Hi-Angel
    Nov 9, 2022 at 19:47
  • I tried killing pulseaudio and running pipewire. but it did not resolve the issues. I have installed Kubuntu and I am having problems even launching jack with firewire. I have forgotten some spell or other, but I will get there. I will see whether pipewire is a help. Thanks for your comment.
    – RML
    Nov 11, 2022 at 13:31
  • 1
    I have discovered the missing spells. Kubuntu does the same thing as Ubuntu Studio. It sets an output Master Channel and then copies out anything on that socket to all the other output sockets. Pipewire is up, next, but I am concerned it may just emulate Pulseaudio's behavior. There must be a way to change alsa or pulseaudio to change the behaviour.
    – RML
    Nov 11, 2022 at 13:55
  • 1
    Summary: qjackctl runs fine with the built-in audio hardware, but will not run with the FFADO firewire driver. The firewire driver runs on the command line, but that misses qjackctl discannecting alsa/pulseaudio or pipewire socket routing thus maintaining inappropriate routings and socket designations. The DAW is still able to play back through the 'mastertrack' socket, but it appears on all firewire interface output ports. qjackctl Connexions shows all the correct connections and socket designations,, but has not been able to iset them up correctly. Getting qjackctl going should put it right.
    – RML
    Nov 12, 2022 at 16:51

1 Answer 1


I have called a halt in trying to resolve this issue.

I have come to the following conclusions:

  • It affects all Ubuntus

  • It is not a problem with pulseaudio/pipewire. pipewire works well in pulseaudio mode, and comes with jack-like patching GUIs. Both only present alsa and jack presented hardware sockets.

  • jack works well with alsa/pipewire and runs with the computer's audio hardware.

  • ffado-test Discover finds the firewire interface:

    03155440799: Debug (Configuration.cpp)[ 209] showSetting:     vendorname = Focusrite
    03155440824: Debug (Configuration.cpp)[ 209] showSetting:     modelname = Saffire Pro10IO
    03155440849: Debug (Configuration.cpp)[ 209] showSetting:     driver = BEBOB
    03155440872: Debug (Configuration.cpp)[ 209] showSetting:     mixer = SaffirePro
  • alsa does not list the firewire interface when the interface is running in jack even if an init or force-reload is issued in Terminal.

  • The file ~/jackdrc (which seems to be saved by studio-controls and qjackctl) does not include the realtime option -R. Changing it to,

    /usr/bin/jackd -nfirewire -R -P60 -u -dfirewire -r44100 -p1024 -n3 -D

    and running it in Terminal starts the firewire audio interface. This is similar to the command I have been using:

    jackd -P60 -R -d firewire

    Please note that this command has worked for many years and I have used it when having similar problems with qjackctl in the past. (this may not be a recent issue).

  • Although both qjackctl and studio-controls may be set to realtime, they don't appear to be sending the -R option to jack.

  • Starting jack and the firewire interface via the commandline and then running qjackctl will often show qjackctl as 'Running' and all of the correct socket designations appear in Graph. kxstudio's catia does the same.

    However, only the 'master socket' is active in my DAW Reaper and the same audio is fed to all of the other output sockets. All input and output sockets have the wrong designations as reported in a sub-comment, above.The 'master socket' can be changed in studio-controls and then only that socket works in the DAW.

  • Although my USB Focusrite Scarlet interface (18 outputs) is not so badly affected, it is not still really usable. I have not tested it extensively, but the socket designations are wrong. I have not tested the inputs, but I suspect only one 'Microphone' socket will work.

I don't think any Ubuntu's will work correctly with multi-channel interfaces, but they probably work well with stereo IN and stereo OUT external interfaces including firewire and USB connected types. pipewire is likely to make blogging and Youtube software reviewing easier, but Ubuntu is not usable atm for band and orchestra multichannel recordings. Back to Windows (sigh!).

  • Excelent research! It's sad you couldn't make it work. I still am not familiar with half the terms, so am not even sure if it's a problem in userspace or a driver for your hw. And I'd like to note that askubuntu is a general purpose Q&A site, where you unlikely to find someone as good in audio. However, you may find such people e.g. on PipeWire issue tracker, so if there's anything in your opinion that may be improved on PW's side that may make your and future user's life easier, don't hesitate to create a report and discuss that with the actual developers.
    – Hi-Angel
    Nov 13, 2022 at 23:43
  • Thanks for your comment. I really wanted to ask the Ubuntu Studio community, but their website only suggests Ask Ubuntu. This site has been a great help on other issues in the past.
    – RML
    Nov 14, 2022 at 14:52
  • I must stop asking for a new line! It might be of interest if I explain a little more. alsa has never had drivers for Firewire hardware, but it does support jack for low latency audio work. Because they did not want Windows to record all the best tunes, the FFADO group built drivers and utilities to support Firewire interfaces on a jack server, knowing that most Linux distributions would support the jack server system. The FFADO drivers have to connect to the jack server, before alsa/pulseaudio/pipewire can see them. Hence the magic spells in Terminal.
    – RML
    Nov 14, 2022 at 15:05
  • I see. So… Does that mean that your next to last sentence in the answer should be "…Ubuntu is not usable atm for Firewire"…? Or do the FFADO's custom drivers work okay with Jack/PipeWire, but then there are problems in the PipeWire specifically?
    – Hi-Angel
    Nov 14, 2022 at 15:11
  • The chances are it will work fine with stereo left and right, which is the norm for home studio. The audio sockets should appear in pipewire and be selectable in the loudspeaker icon in the system tray (Audio Volume). In the past, this was not possible. However, if you have an interface with eight or 16 output ports, that needs jack to be running and that has stopped working for Firewire audio interfaces in Ubuntu. Firewire is a legacy system and most modern audio interfaces use USB. I just wanted to use my old Saffire interface out on the road. Stereo Firewire interfaces are quite rare.
    – RML
    Nov 15, 2022 at 16:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .