I've just bought an Alienware M15 R7 and installed Ubuntu 22.04 LTS on it and Wi-Fi is not working. I tried to follow multiple solutions, but none of them worked for me.

I'm getting the message.

enter image description here

sudo lshw -c network

giorge@giorge-Alienware-m15-R7:~$ sudo lshw -c network
  *-network UNCLAIMED       
       description: Network controller
       product: Alder Lake-P PCH CNVi WiFi
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: iomemory:620-61f memory:6235284000-6235287fff
       description: Ethernet interface
       product: Killer E3000 2.5GbE Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:3a:00.0
       logical name: enp58s0
       version: 06
       serial: 04:bf:1b:17:47:34
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.17.0-1020-oem duplex=full firmware=rtl8125b-2_0.0.2 07/13/20 ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:18 ioport:3000(size=256) memory:8f100000-8f10ffff memory:8f110000-8f113fff

rfkill list all

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

uname -mrs

Linux 5.17.0-1020-oem x86_64

grep wl /etc/modprobe.d/*

/etc/modprobe.d/broadcom-sta-common.conf:# wl module from Broadcom conflicts with ssb
/etc/modprobe.d/broadcom-sta-common.conf:install wl /sbin/modprobe --ignore-install wl $CMDLINE_OPTS
/etc/modprobe.d/broadcom-sta-dkms.conf:# wl module from Broadcom conflicts with the following modules:
/etc/modprobe.d/iwlwifi.conf:# /etc/modprobe.d/iwlwifi.conf
/etc/modprobe.d/iwlwifi.conf:# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
/etc/modprobe.d/iwlwifi.conf:# microcode file installed on the system.  When removing iwlwifi, first
/etc/modprobe.d/iwlwifi.conf:# remove the iwl?vm module and then iwlwifi.
/etc/modprobe.d/iwlwifi.conf:remove iwlwifi \
/etc/modprobe.d/iwlwifi.conf:(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \

And there's no Wireless driver in Software & Updates -> Additional Drivers.

enter image description here

I've tried the following solutions:

  1. rfkill unblock all;
  2. sudo apt-get reinstall network-manager;
  3. ubuntu-20-04-no-wifi-adapter-found-dell

Can someone help me with this issue? Thanks!


Adding output of lspci -nnk | grep -iA3 net; dmesg | grep iwl

0000:00:14.3 Network controller [0280]: Intel Corporation Alder Lake-P PCH CNVi WiFi [8086:51f0] (rev 01)
    Subsystem: Rivet Networks Device [1a56:1672]
    Kernel modules: iwlwifi
0000:00:15.0 Serial bus controller [0c80]: Intel Corporation Alder Lake PCH Serial IO I2C Controller #0 [8086:51e8] (rev 01)
    Subsystem: Dell Device [1028:0b54]
0000:3a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. Killer E3000 2.5GbE Controller [10ec:3000] (rev 06)
    Subsystem: Dell Killer E3000 2.5GbE Controller [1028:0b54]
    Kernel driver in use: r8169
    Kernel modules: r8169
dmesg: read kernel buffer failed: Operation not permitted


Adding output of sudo dmesg | grep iwl

[    2.038814] Loading modules backported from iwlwifi
[    2.038815] iwlwifi-stack-public:master:9858:4c7cba27
[    2.232493] iwlwifi: Unknown symbol iwl_mei_is_connected (err -2)
  • Please edit to include results from terminal for lspci -nnk | grep -iA3 net; dmesg | grep iwl
    – Jeremy31
    Nov 5, 2022 at 19:16
  • a wireless usb adapter should do the trick Nov 5, 2022 at 19:35
  • @Jeremy31 I've added it! Nov 5, 2022 at 19:45
  • I would like to use the existing wireless adapter, once it's a notebook. Nov 5, 2022 at 19:45
  • 1
    I would be very surprised to find that you actually needed backport. I also suspect that backport is not compatible with your 5.17 kernel version. I suggest that you do: sudo apt purge backport-iwlwifi-dkms Reboot and show us a new version of: sudo dmesg | grep iwl
    – chili555
    Nov 5, 2022 at 20:22


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy