0

Viber is working very well until I add Bulgarian(phonetic) keyboard in settings as additional input language. After removal of Bulgarian (phonetic) it works again. If I click on icon nothing is open. I tried opening Viber with terminal and here is what terminal says. I hope someone can help me how to fix this issue so I can have both keyboard languages. Until then I changed settings every time before I launch viber and then set it back to type in my native language.

ivan@ivan-767466g:~$ /opt/viber/Viber %u

qt.webenginecontext:

**

GLImplementation: desktop
Surface Type: OpenGL
Surface Profile: NoProfile
Surface Version: 2.1
Using Default SG Backend: yes
Using Software Dynamic GL: no
Using Angle: no
Init Parameters:
  *  allow-loopback-in-peer-connection  
  *  application-name ViberPC 
  *  autoplay-policy no-user-gesture-required 
  *  browser-subprocess-path /opt/viber/libexec/QtWebEngineProcess 
  *  disable-features DnsOverHttpsUpgrade,ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture,AudioServiceOutOfProcess 
  *  disable-setuid-sandbox  
  *  disable-speech-api  
  *  enable-features NetworkServiceInProcess,TracingServiceInProcess,NetworkServiceInProcess 
  *  enable-threaded-compositing  
  *  enable-usermedia-screen-capture  
  *  in-process-gpu  
  *  use-gl desktop 
xkbcommon: ERROR: Couldn't process include statement for 'de(phonetic)'
xkbcommon: ERROR: Abandoning symbols file "(unnamed)"
xkbcommon: ERROR: Failed to compile xkb_symbols
xkbcommon: ERROR: Failed to compile keymap
[3151:3177:1103/182923.815328:FATAL:xkb_keyboard_layout_engine.cc(640)] Keymap file failed to load: de-phonetic
Trace/breakpoint trap (core dumped)

**

Thank you in advance for help.

4 Answers 4

5

I found acceptable solution for the problem. In keyboard layout settings you should place in my case Bulgarian at first place in order.(but I think Serbian and other languages may cause same problem.) Every other place in settings menu will case this error.

1

I can confirm that latest viber version 18.2.0.2 doesn't want to start on ubuntu 22.04 if you have multiple keyboard layout that includes serbian and probably other similar languages.

The solution is to remove all other keyboard layouts except English(US) and then you can start viber and use it normally. Afterwards, you can add other keyboard layouts. The only problem is that you have to do it every time you reboot your PC.

1

Thanks @hopetech a thumb up! I confirm the issue was resolved.

I run over the same problem with Ubuntu 22.04.1 LTS (Jammy Jellyfish) (gdm3 desktop environment) and Debian 11 (bullseye) Cinnamon (desktop environment). After upgrade viber from old version 16.1.0.37 to 18.2.0.2 it doesn't start at all. Only old AppImage version 16.1.0.37 started.

I just reorder layouts as in the pictures bellow:

enter image description here enter image description here

and viber 18.2.0.2 started as expected. No mater if installed from .deb or AppImage version. I hope this will help others who meet the issue.

0

Comfirmed for Kubuntu 22.04. The English language should not be the first in the keyboard layout list here. Odd issue :)

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .