Since I have updated to 12.04 LTS my desktop pc's fan runs permanently with high speed and is annoyingly noisy. CPU temperature is low. Here is what the sensors command gets me:

Adapter: PCI adapter
temp1:        +48.0°C  (high = +100.0°C, crit = +115.0°C)

Adapter: ISA adapter
Core 0:       +39.0°C  (high = +82.0°C, crit = +100.0°C)
Core 1:       +40.0°C  (high = +82.0°C, crit = +100.0°C)
Core 2:       +37.0°C  (high = +82.0°C, crit = +100.0°C)
Core 3:       +44.0°C  (high = +82.0°C, crit = +100.0°C)

Adapter: ISA adapter
+3.3V:        +3.34 V  
3VSB:         +3.38 V  
Vbat:         +3.23 V  
fan1:        1675 RPM
fan2:         959 RPM
fan3:           0 RPM  ALARM
fan4:           0 RPM
temp1:        +42.0°C  (high = +70.0°C, hyst = +60.0°C)
temp2:        +25.0°C  (high = +100.0°C, hyst = +85.0°C)
temp3:        +24.0°C  (high = +100.0°C, hyst = +85.0°C)

Same issue of noisy fan has been noted in Dell 1555 after upgrade to 12.04 with output of sensors command as below:

Adapter: Virtual device
temp1:        +51.0°C  (crit = +100.0°C)
temp2:        +59.0°C  (crit = +100.0°C)
temp3:        +79.0°C  (crit = +100.0°C)

Adapter: PCI adapter
temp1:        +80.0°C 

Is there a way to figure out which application is causing it?

  • Have you checked top and/or powertop to check which application is producing such a heavy load? – pl1nk May 30 '12 at 0:32

Same here, and solved with jupiter. It seems there's nothing you can do with that, so the best is keep them low via software when you don't need much power.

sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter

You may try this http://kastang.com/blog/2009/08/manually-change-ati-fan-speed-in-ubunt/

I tested on my 7950 and it works fine (put 0% is ok)

The main part is:

To check the temperature of your card: aticonfig --adapter=0 --od-gettemperature

To change the fan speed: aticonfig --pplib-cmd "set fanspeed 0 XX"

(Where the XX is replace it with the fan speed percentage)

I also found that compiz cpu was high -> tried this: https://askubuntu.com/a/127310/26508 and it works too.

I reproduce the main part here:

Just backup (rename) ~/.compiz-1 and ~/.config/compiz-1 directories and let them to be created again with the default settings (you'll need to logout and log back in again).

mv ~/.compiz-1 ~/.compiz-1.BACKUP

mv ~/.config/compiz-1 ~/.config/compiz-1.BACKUP

After having restarted and confirmed that everything works as expected, you can simply remove these backups (unless you have a use for them).

  • While this may theoretically answer the question it would be preferable to include the information here and leave the links as references. – Mark Paskal Mar 11 '13 at 21:48
  • @MarkPaskal totally agree - done – unludo Mar 12 '13 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.