1

I have Xubuntu 22.04. This is the first time I've ever seen this problem: when I press Alt+Tab, the preview bar, that is, the horizontal bar of windows icons that shows which window would receive the focus when the Alt key is released, suddenly stopped appearing. This caused there to be no feedback at all when cycling windows, so I just have to guess or remember which window would get the focus when I release the Alt key.

I have no idea what action might have caused this problem. I rebooted the machine, but the problem is still there.

In Settings ► Window Manager ► Keyboard, the keystroke Alt+Tab is still mapped to the action "Cycle windows". In Settings ► Window Manager Tweaks ► Cycling, the checkboxes have the following values:

  • Skip windows that have "skip pager" or "skip taskbar" properties set: unchecked
  • Cycle through minimized windows in most recently used order: unchecked
  • Include hidden (i.e. iconified) windows: checked
  • Cycle through windows on all workspaces: unchecked
  • Draw frame around selected window while cycling: checked
  • Raise windows while cycling: unchecked
  • Cycle through windows in a list: unchecked

After the problem manifested itself, I checked the "Draw frame around selected window while cycling" checkbox, to get some feedback on what window would receive the focus, but this is a suboptimal workaround.

I can't find any setting that would make the preview bar disappear. I googled for possible solutions, but can't find any.

I have an external monitor attached to my laptop, but I've set the screens to mirror each other. The laptop screen is indeed identical: no preview bar appears on pressing Alt+Tab.

The screenshot below shows my screen when I've pressed Alt+Tab and not yet released the tab. The rectangle of the window that would receive the focus is highlighted, but there's no preview bar.

screenshot of my monitor

1 Answer 1

1

So this was due to a silly mistake I must have made accidentally. The following actions resolved the problem:

  • Open Settings ► Window Manager Tweaks ► Compositor
  • uncheck the "Show windows preview in place of icons when cycling" setting

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .