I'm running Ubuntu 20.04.5. Recently all of my system tray application icons (e.g. Dropbox, Discord) disappeared, and restarting did not help. When I run Dropbox or Discord from terminal, their outputs both include the following error (among a lot of other output):

libappindicator-WARNING **: 17:17:54.679: Unable to connect to the Notification Watcher: GDBus.Error:org.gnome.gjs.JSError.ValueError: domain.replaceAll is not a function

Similarly, when I run OBS or Talon (dictation software) from terminal, I get a related error:

QDBusTrayIcon encountered a D-Bus error: QDBusError("org.gnome.gjs.JSError.ValueError", "domain.replaceAll is not a function")

These programs all run normally otherwise, but I really want the tray icons back because some functionality can only be accessed from there. I searched up these errors but couldn't find anything useful.

Things that could have triggered this: the Software Updater recently updated some software, but I didn't pay attention to what was updated. Also, I only recently installed Talon. Both were shortly before the tray icons disappeared. I also use a GNOME extension/tweak called Icon Hider to hide some system tray icons, but I have been using that for months with no problems. Enabling and disabling the extension also did not solve the problem.

Does anyone know what might be causing this or how I can fix it?

3 Answers 3


This seems to be fixed here:


You can manually apply this fix in ~/.local/share/gnome-shell/extensions/[email protected]/util.js by changing this line (about 470)

Logger._domain = domain.replaceAll(' ', '-');


Logger._domain = domain.replaceAll ? domain.replaceAll(' ', '-')
    : domain.split(' ').join('-');

Under X11, you may need to restart GNOME Shell (Alt+F2, r, ⏎) after that. Under Wayland you need to logout and login again.

Doing this fixed the problem for me until a new version is released.

  • Thanks, this solved my problem
    – ericc
    Nov 11, 2022 at 10:17
  • Thank you!! It turns out I installed this appindicator extension as part of setting up Talon, and then totally forgot about it. I don't need the extension right now, so disabling it solved my problem.
    – rayna
    Nov 21, 2022 at 2:05

Same version 20.4.5 LTS, same issue
All my tray application icons disappeared after an update a few weeks ago.
I'm not using Talon or the extension "Icon Hider"

This is the error I'm seeing with "diodon", a clipboard manager :

(diodon:3931): libappindicator-WARNING **: 15:08:25.977: Unable to connect to the Notification Watcher: GDBus.Error:org.gnome.gjs.JSError.ValueError: domain.replaceAll is not a function

I had a similar problem in Zorin OS Core 16.2 (Ubuntu 20.04) and solved in 2 steps. First, install gnome-shell-extension-appindicator via terminal (sudo apt install gnome-shell-extension-appindicator). And, finally, install the extension AppIndicator and KStatusNotifierItem Support by 3v1n0 (AppIndicator and KStatusNotifierItem Support - GNOME Shell Extensions). Reference: how to use a tray icon. That's it. And if you also want minimize any program to the system tray, you can install the program called Kdocker (but it is still required doing the 2 steps mentioned before).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .