santos@santos:~$ rfkill list
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

*-network DISABLED
description: Wireless interface
product: BCM4313 802.11b/g/n Wireless LAN Controller
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:04:00.0
logical name: eth2
version: 01
serial: ac:81:12:22:cb:38
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=wl0 driverversion= latency=0 multicast=yes wireless=IEEE 802.11
resources: irq:17 memory:f2500000-f2503fff

any solution ?

  • 1
    So is there a hardware switch and did you turn it on? According to a Google search it might be Fn+F5 or a tiny switch at the front or side of the laptop. – elmicha May 29 '12 at 17:21
  • 1
    Yeah its . i do turn it on and still under the network icon i see the words that wireless is disabled by hardware switch and when i do pressing Fn+F5 nothing happen .. – santosamaru May 29 '12 at 18:33
  • Ok. Does this and/or this answer help? – elmicha May 29 '12 at 20:50

I had a similar problem with my Lenovo Z570. There are two potential issues going on... One is related to hardware, the other software.

For the software end of things, your laptop is most likely suffering from "Multiple WiFi Personalities". Basically, the way I understand it, Ubuntu is not clear on which wifi drivers should be loaded based on incompatibilities with the hardware (this is just how I understand it... I could be wrong =).

The simple & temporary test is to blacklist "acer-wmi" (from terminal):

sudo rmmod -f acer-wmi
sudo rfkill unblock all
rfkill list all

if that stets all of your blocks to "no", you are in business... simply edit your /etc/modprobe.d/blacklist.conf file to blacklist that item and you are good to go.

sudo gedit /etc/modprobe.d/blacklist.conf

When the editor opens, add blacklist acer-wmi as a new line at the end of the file. Save and Exit. then type in the following just to double check things:

rfkill list all

If you still see any "Hard blocked: yes" entries at this point, you have one of three things going on. Either your physical wifi switch is in the off position (if you have one... my z570 has it on the front bezel), your software switch is off (Fn+F5 on my z570) or you may need to simply reset your Bios.

For me it took resetting my Bios to fix it. Simply restart your laptop and press F2 at boot up. Once in the Bios, press F9 to reset the Bios, followed by F10 to save and exit. Test your wifi now. If it's working, you can now head back to your bios and get things setup the way you like them again.

It took a TON of digging and trial and error until I finally got this working. I hope you don't have the same perils!

| improve this answer | |

Ditto on the bios reset. My Lenovo Z570 didn't see wireless even after a full wipe and install of Quantal; I had to do the F9 bios reset. It works perfectly now.

I have also posted the solution at: http://thecowgirlcoder.com/2012/10/18/lenovo-z570-phy0-hard-blocked-solution/

| improve this answer | |

I am having similar issues on my s205.

On a previous install (12.04), I had Ubuntu appearing as an item in the boot list in bios. The recommended solution to that was to make sure your HDD was listed higher in boot order (as suggested by alex).

When I ran updates, it would periodically cause this Ubuntu item to be pushed up the list again, and again I would move it.

More recently, I have installed 13.04. This was after a very painful process of trying to get anything to install, and boot on the machine. [The solution to that was to change the name and location of my efi file to be exactly /EFI/boot/bootx64.efi on the efi partition, but I should leave that to a different post.]

Anyway, this most recent install left me with the same issue that the wifi seems to be switched off by the hardware switch, and no amount of blacklisting or switching actual hardware switches changes this. Unfortunately, there is no longer an Ubuntu item in the bios. Arrghh.

Well. I have a working solution, but it ain't pretty. Every time I boot the machine, I press fn+f11 (=f12) to enter the custom boot screen. I then toggle the highlighted items back and forth, and then boot from HDD. I don't know how I discovered that this worked, but nothing else I have tried does. So there you go. If anyone can find an uglier workaround to a software issue, I haven't come across it. In the mean time, it seems to work.

Well, I say that. But I recently drained the battery. And my 'method' lost its mojo. I had to reset the bios. After which, my ugly workaround is again working.

I would love to hear if anyone has a better solution, but if you have a Lenovo Ideapad s205, model number 1038, and nothing else works. Then try this.

| improve this answer | |

move hard disk above ubuntu in boot order in BIOS (restart, hit f2)

source lenovo s205

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.