I have Precise 12.04 installed as the host OS. In VirtualBox,I also have installed 12.04.

I am not able to connect the Virtual 12.04 to the host internet. I have tried selecting all the available options in the network adapters (NAT,Host only,Bridge,etc), but non of them is working. In the some options some stuff has to be entered manually, which I do not know what to enter.

Where am I going wrong in the settings?

  • NAT network should work out of the box. Can you provide some detail about your host network configuration? – Javier Rivera May 30 '12 at 6:58
  • Yeah it worked...with ubuntu...i've answered my own question below..(PS: would like help with the android stuff if possible ;)) – Nirmik May 30 '12 at 7:16

The NAT connection needed to be selected with the hardware being:

AMD PCNet FAST III (Am79C973, the default)

This works with almost any OS (as mentioned on the Virtualbox help page). The Intel setting for some reason did not work.

For Network setups with heavy router settings, you may have to use Bridged option with "PCNet FAST III" as the default.

| improve this answer | |
  • you should accept your own answer to close the question. Note for the future - please do not add "solved" to the question title. You just accept the answer to close. Thanks. – fossfreedom May 30 '12 at 8:19
  • @fossfreedom I tried accepting it,but it says i can accept it 2morrow.. and i'll take a note of the SOLVED thing.actually i had read somewhere that this should be done,so I did it...but it seems that was wrong info.. thanx.. :) i'll accept the answer asa m allowed to. :) – Nirmik May 30 '12 at 8:21
  • For some reason the first Intel adapter type stopped working for me. AMD PCNet FAST III didn't either. So I just went down the list until I got to Intel PRO/1000 MT Server (82545EM), which finally worked (I'm on an Early 2013 MBP Retina running El Capitan). – Lèse majesté Oct 26 '16 at 20:16

VB likely made a "Unidentied Network" connection to your real machine and it uses this as its source for internet connection. Follow the settings below to check your basics for getting internet to work in you virutal OS.

Network Settings: *Select NAT under "Attached to:" *"Adapter Type:" MT Desktop (only can be changed when vm power is shut off) *"Cable connected" box is checked

System Settings: *"Network" box is checked in the "Boot Order:" listing.

| improve this answer | |

Just wanted to let everybody know that I fixed the issue by uninstalling Virtualbox from the Software Centre, and by installing the copy I found on virtualbox.org website. Then I also set the adapter to AMD PCNet FAST III (Am79C973, the default)

| improve this answer | |

Using Debian in my VM, i had to edit the /etc/network/interfaces to use the eth0 as the default loopback interface:

auto eth0
iface eth0 inet dhcp
| improve this answer | |

Remove all virtualbox packages from system then install package from Virtualbox.org it's all because of missing /usr/lib/virtualbox/VBoxNetNAT binary , internet access in NAT network mode doesn't work. This is not a default option NAT.

Normally it should run this file like:

/usr/lib/virtualbox/VBoxNetNAT --ip-address --netmask --network NatNetwork --trunk-type whatever

But without this file, guest only get IP Address from DHCP server and it can't connect to Internet. Communication between guest works very well.

After uninstalling all virtualbox packages and installing package (5.1.4-110228~Ubuntu~trusty) from VirtualBox.org , /usr/lib/virtualbox/VBoxNetNAT connect to Internet very well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.