16

So, I just installed Ubuntu Unity 22.10. The installation was fine, but booting into the system, there was no sound. In the sound settings, I could only find an output called "Dummy Sound".

screeshot of Sound settings

I have tried many solutions but none of them worked, mainly because I get another error when I try to run some dpkg commands:

Bus error (core dumped)
dpkg: error processing package linux-image-5.19.0-23-generic (--configure):
 installed linux-image-5.19.0-23-generic package post-installation script subprocess returned error exit status 135
Errors were encountered while processing:
 linux-image-5.19.0-23-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

The solutions I tried are these:

I have tried reinstalling pulseaudio, removing pipewire, installing wireplumber (which was one solution that got me the output I gave above).

Some outputs to give some info:

$ lspci -nnk | grep -A2 Audio
30:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Renoir Radeon High Definition Audio Controller [1002:1637]
    Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Renoir Radeon High Definition Audio Controller [1002:1637]
    Kernel modules: snd_hda_intel
30:00.2 Encryption controller [1080]: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor [1022:15df]
--
30:00.6 Audio device [0403]: Advanced Micro Devices, Inc. [AMD] Family 17h/19h HD Audio Controller [1022:15e3]
    DeviceName: Realtek ALC1220
    Subsystem: Micro-Star International Co., Ltd. [MSI] Family 17h/19h HD Audio Controller [1462:ec56]
    Kernel modules: snd_hda_intel

$ pacmd list-cards
1 card(s) available.
    index: 0
    name: <alsa_card.usb-Generalplus_Usb_Audio_Device-00>
    driver: <module-alsa-card.c>
    owner module: 7
    properties:
        alsa.card = "1"
        alsa.card_name = "Usb Audio Device"
        alsa.long_card_name = "Generalplus Usb Audio Device at usb-0000:16:00.0-9.3, full speed"
        alsa.driver_name = "snd_usb_audio"
        device.bus_path = "pci-0000:16:00.0-usb-0:9.3:1.0"
        sysfs.path = "/devices/pci0000:00/0000:00:02.1/0000:16:00.0/usb1/1-9/1-9.3/1-9.3:1.0/sound/card1"
        udev.id = "usb-Generalplus_Usb_Audio_Device-00"
        device.bus = "usb"
        device.vendor.id = "1b3f"
        device.vendor.name = "Generalplus Technology Inc."
        device.product.id = "2008"
        device.product.name = "Usb Audio Device"
        device.serial = "Generalplus_Usb_Audio_Device"
        device.string = "1"
        device.description = "Usb Audio Device"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-usb"
    profiles:
        input:mono-fallback: Mono Input (priority 1, available: unknown)
        off: Off (priority 0, available: unknown)
    active profile: <input:mono-fallback>
    sources:
        alsa_input.usb-Generalplus_Usb_Audio_Device-00.mono-fallback/#0: Usb Audio Device Mono
    ports:
        analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-input-microphone"
4
  • Please can you add which dpkg and ldd $(which dpkg) to your question?
    – nobody
    Oct 26, 2022 at 11:27
  • 1
    I think I had the same Issue. I kinda fixed it by running systemctl --user start pulseaudio, but after reboot it happened again. Hope this helps, although I hope there will be some patch from the Devs
    – isi_ko
    Oct 27, 2022 at 15:18
  • The question is , why Ubuntu get reed of things that works and not using any alternative to it? the solution from David bring the sound back. askubuntu.com/questions/1403665/…
    – yop
    Dec 21, 2022 at 6:46
  • 2
    Does this answer your question? No sound output devices listed after upgrade from 21.10 to 22.04 Dec 21, 2022 at 13:21

6 Answers 6

41

I had the same issue, but this solution helped me: No sound output devices listed after upgrade from 21.10 to 22.04

sudo touch /usr/share/pipewire/media-session.d/with-pulseaudio
systemctl --user restart pipewire-session-manager
3
  • 1
    Great answer - thank you Jan 14 at 16:00
  • This solution Works great on upgrading from 22.04 to 22.10 where there is no audio and the control only shows a dummy output Feb 27 at 14:57
  • I couldn't start, or restart, the pipewire service. I just got a bus error about a missing device. It seems the upgrade didn't install all of Pipewire. Apr 10 at 13:53
6

I reinstalled my system many times in order to see what solution did it right.


Finally I had to follow all those steps:

  1. ln -s /usr/share/pipewire /etc/pipewire
  2. sudo touch /usr/share/pipewire/media-session.d/with-pulseaudio
  3. systemctl --user restart pipewire-session-manager
  4. systemctl --user start pulseaudio
  5. reboot

If one of those steps wasn't done, the audio didn't came up.

I did found information about intel audio drivers/settings, but it didn't make a difference. So I did not need it on my last installation.

This after a clean install of Ubuntu server 22.10 (5.19.0-23-generic) with Cinnamon 5.4.12 as only desktop environment using muffin and slick-greeter.

Special thanks to all of you for the provided information !


I made a bash menu to do this quickly when I need to reinstall my system. It can be found here.

4
  • After my last update today, I have no sound at all.
    – user849355
    Dec 3, 2022 at 0:11
  • I didn't find any solution to solve it on Ubuntu 22.10. I tried to dist-upgrade to solve unmet dependencies, but, it got worse. So I reinstalled the all system (to 22.04 LTS) without deleting "home", and followed these instructions to make it work again after installation.
    – user849355
    Dec 4, 2022 at 14:59
  • It seem to me that Cinnamon (puseaudio and alsa) is using another sound system as Ubuntu (pipewire) does. Those can work in a kind of corssover, but it gets in trouble when upgrading to retain those crosovers. Something like that ... I think.
    – user849355
    Dec 4, 2022 at 15:05
  • Thank you, that works for me after upgrade to Ubuntu 23.04. One change I had to do is only to reboot before starting pulseaudio
    – edwgiz
    Jul 27 at 14:40
2

Solution for my case - after upgrading from 22.04 to 22.10:

Install libraries:

sudo apt install libldacbt-{abr,enc}2

sudo apt install libspa-0.2-bluetooth pipewire-audio-client-libraries pipewire-media-session

sudo cp /usr/share/doc/pipewire/examples/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/

After reboot, it starts working.

3
  • This led me to working sound, but I think the first line concerns Bluetooth libraries that I didn't need and I suspect people using onboard sound won't need. Apr 10 at 13:54
  • no joy for me :-( Apr 14 at 4:36
  • Works for me thanks :) Sep 30 at 21:58
0

What fixed this for me was to copy the pipewire folder from /usr/share to /etc. I then rebooted, and it all just worked.

2
  • this did not work in my case Oct 31, 2022 at 20:27
  • @Odd Egil Hansen - It did work for one of my computers, where all other tries (install - add intel hda - - and more) didn't succeed. This was a clean install of the system with Cinnamon desktop on Ubuntu server 22.10.
    – user849355
    Nov 12, 2022 at 1:33
0

I also had no sound after the upgrade. My machine has a Threadripper 3960x which uses an ALC1220 USB solution for audio. After the upgrade I only had the dummy devices for my speakers and my input.

What worked in the end for me is the following:

  • sudo apt install libldacbt-{abr,enc}2
  • sudo apt install wireplumber
  • systemctl --user --now enable wireplumber.service

Immediately after the last command the devices appeared in gnome settings, and sound worked. Only problem left is that I always have to switch output from dummy to Speakers - USB after every boot.

-1

The following code has fixed my problem with the sound during upgrade Ubuntu 22.04 to 22.10

sudo touch /usr/share/pipewire/media-session.d/with-pulseaudio systemctl --user restart pipewire-session-manager

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .