1

I recently installed Ubuntu 22.04 on a Lenovo ThinkPad. The system uses the local WiFi connection configured during setup (I can access the Internet just fine), but the WiFi adapter is shown as "unavailable" in all GUI/Gnome settings. iwconfig displays the WiFi interface (wlp4s0) along with WiFi SSID:

lo        no wireless extensions.

enp0s31f6  no wireless extensions.

wlp4s0    IEEE 802.11  ESSID:"MySSID"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: 04:42:1A:9C:92:14   
          Bit Rate=866.7 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=53/70  Signal level=-57 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:460   Missed beacon:0

lshw -C network also lists the interface with the native driver (iwlwifi):

  *-network                 
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlp4s0
       version: 3a
       serial: 44:85:00:f4:9d:db
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.15.0-50-generic firmware=36.ca7b901d.0 8000C-36.ucode ip=192.168.78.6 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:128 memory:f1000000-f1001fff

lsmod outputs the following:

iwlwifi         450560 1 iwlmvm
cfg80211        974848 3 iwlmvm,iwlwifi,mac80211

rfkill says:

ID TYPE      DEVICE                   SOFT      HARD
 0 bluetooth hci0                unblocked unblocked
 1 bluetooth tpacpi_bluetooth_sw unblocked unblocked
 2 wlan      phy0                unblocked unblocked

The output of nmci d is:

DEVICE     TYPE      STATE        CONNECTION 
wlp4s0     wifi      unavailable  --         
enp0s31f6  ethernet  unmanaged    --         
lo         loopback  unmanaged    --         

And my netplan configuration files contain the following (I added the local nameserver and the dhcp-overrides section manually):

# 00-installer-config-wifi.yaml
# This is the network config written by 'subiquity'
network:
  version: 2
  wifis:
    wlp4s0:
      access-points:
        MySSID:
          password: mypasswd
      dhcp4: true
      dhcp4-overrides:
        use-dns: false
      nameservers:
        addresses: [192.168.78.42]
# 00-installer-config.yaml
# This is the network config written by 'subiquity'
network:
  ethernets:
    enp0s31f6:
      dhcp4: true
      optional: true
  version: 2

The only connection problem is that local connections (via SSH or HTTP) to the system sometimes only work from specific devices, while other devices return an error (time out/no route to host/host is down). The failed connection attempts do not appear in /var/log/auth.log, although successful connections are logged. This can be fixed temporarily by initiating any connection (e.g. ping) from the system to the device incapable of establishing a connection, and then connecting to the system again. I am not sure whether this is related to my actual question:

How can I "activate" the WiFi adapter in Gnome (e.g. to connect to different WiFi networks)?

Thanks, Jan

3
  • Please edit your question to include the results of these terminal commands: cat /etc/netplan/*.yaml and also: nmcli d Please redact with xxx any passwords. Welcome to Ask Ubuntu.
    – chili555
    Oct 14, 2022 at 20:58
  • Thank you – I added the output of all commands mentioned, along with the content of /etc/netplan/*files.
    – janeden
    Oct 15, 2022 at 6:11
  • You configure network either by netplan, or by Network Manager that you call "visible on gnome". You used the first way. Si it is not "visible".
    – Pilot6
    Oct 15, 2022 at 9:34

1 Answer 1

6

To activate the connections in Gnome, actually Network Manager, revert all of your netplan entries:

sudo rm /etc/netplan/00-installer-config-wifi.yaml

Write a new netplan file:

sudo nano /etc/netplan/01-network-manager-all.yaml

Add the following:

# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager

Follow with:

sudo netplan generate
sudo netplan apply
sudo service NetworkManager restart

It might take a reboot.

2
  • 1
    Thanks again – that worked! Your solution (and Pilot6's comment above) made me aware that by installing Ubuntu Server first (and Ubuntu Desktop subsequently via apt-get) I implicitly and unintentionally chose the netplan method.
    – janeden
    Oct 15, 2022 at 13:52
  • Wow worked for me (been months on this problem) thank you chili555 may all your chilies be blessed 👍 Jul 21, 2023 at 4:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .