I am currently trying to buy a 2in1 laptop for my studies and want to install Ubuntu on it.

I already bought two different laptop models.

With the first one, the installation of Ubuntu failed and it reported that this error was most likely caused by hard disk failure. After this error, I could not get the hard disk to show up at all anywhere (not in Ubuntu Live, System Rescue CD, GParted Live or BIOS).

Now I thought this was due to the SSD being broken at arrival. So I bought a different model but the behaviour is the same and now I sit here with two broken laptops. I think it is highly unlikely that both new laptops had broken SSDs from the start but instead most likely that the Ubuntu Installation is actually actively corrupting the SSD and bricking the laptops.

Is that error known? I could not find anything here or via Google. And is there any way to save the SSDs?

Thank you very much in advance.

P.S.: The laptop models were Lenovo Ideapad Flex 5 Gen 7 AMD & Lenovo Thinkbook 14s Yoga Gen 2.

  • Ubuntu does not break hard drives. Did you update the firmware on the ssd drives before starting the install? If the SSD came from the same lot sure you could have 2 broken or appear to be broken in a row. How did you try to install Ubuntu?
    – David
    Oct 13, 2022 at 13:53
  • No I did not update the SSD firmware before and I was unaware that this could be required. I ordered the laptops from two different vendors & Windows ran fine on them. I installed Ubuntu via USB. I used Rufus to create a bootable USB stick in ISO mode with the newest Ubuntu version and used the GPT partition scheme.
    – dolm
    Oct 13, 2022 at 13:57
  • Do not know if gen 2 or not: work arounds for various issues. wiki.archlinux.org/title/Lenovo_Yoga_14s_2021
    – oldfred
    Oct 13, 2022 at 14:12
  • GPT is a very old and not used system since about 2012. If they came with Windows installed they were prepared as EFI. In Rufus you probably should have made the boot USB EFI, Did you verify the ISO you downloaded? ubuntu.com/tutorials/how-to-verify-ubuntu#1-overview. I suggest re down load the ISO and verify it. Make a new Rufus boot device set as EFI. Make sure in BIOS that EFI is selected. You never said are you making dual boot or only Ubuntu. A lot more info is needed in the question.
    – David
    Oct 13, 2022 at 14:14
  • 1
    UEFI strongly suggests using gpt, Microsoft requires gpt partitioning with all UEFI installs. Ubuntu will let you use MBR, but really should not. MBR is from the early 1980's and has many limitations. But whether gpt or MBR, a drive is a drive, and should work. And many vendors now have new systems that are only UEFI. I have a new Dell with Intel 11th gen chip, so not bleeding edge. Kubuntu installed without issue.
    – oldfred
    Oct 13, 2022 at 17:10

1 Answer 1


It seems that this happens on newer Lenovo laptops This has happened 4 times now on 2 different Laptops.

Lenovo Legion 5 with 12700h, and IdeaPad3 with Ryzen 7 5825u (I can not tell you the exact models as both laptops are sent in for servicing)

I have first tried with Ubuntu 20.04 and then with 22.04. It starts installing fine it will boot, and after the entire system becomes unstable( freezes, file manager is not opening etc.), it also failed once mid installation, and from this point on I am forced to turn off the laptops by holding the power button. Upon next boot no boot device is found. If I enter the BIOS the SSD is no longer recognized, it just says no installed device. I have tried removing the SSD and put it on another computer, and it is still not found. I tried booting from a live Linux USB, and it sees some folders, but whenever I try to access those, it gives me a message that the Disk is corrupted. I have multiple older Lenovo laptops for my company and this is the first time I am experiencing this.

For the comments above, the bootable USB was created with Rufus and GPT was selected for the partitioning system. In the BIOS, boot mode is UEFI only, so I don't think that OP did something wrong here, it looks like it is either a batch of bad SSDs, or I think that this can be connected with enabling Secure boot and how the keys are stored.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.