Through VirtualBox for many Virtual Machines for Ubuntu Server - for each one an upgrade was done from 20.04 to 22.04. The apt update and apt upgrade commands work fine. But just few days ago I did realize that if I execute the following command to all the Virtual Machines:

VBoxClient --version

arises the following error message

VBoxClient: error while loading shared libraries: libXt.so.6: cannot open shared object file: No such file or directory

was reinstalled VirtualBox Guest Additions and the situation remains.


  • How fix this situation?

Extra Question

  • Why this situation appeared? Is due the OS' upgrade?


In the post:

is indicated as solution execute the command

sudo apt install libxt6:i386

It shows

E: Unable to locate package libxt6:i386

Thus was executed

sudo apt install libxt6

And was installed.

But sadly even if the VM is restarted, the error remains


2 Answers 2


On a fresh Debian 11, running in VirtualBox 7, I got just the same behaviour:

$ VBoxClient --version
VBoxClient: error while loading shared libraries: libXt.so.6: cannot open shared object file

...after initially installing only the following packages:

apt-get install dkms linux-headers-$(uname -r) build-essential

Turns out I had to also install the following:

apt-get install libxt6 libxmu6

...and now I'm getting, without reboot:

$ VBoxClient --version
  • 1
    Thank you - it worked directly with sudo apt install libxt6 libxmu6 Oct 27, 2022 at 23:46
  • Just being curious, how did you know why to use libxmu6? Oct 28, 2022 at 0:16
  • 1
    VBoxClient was complaining that libXmu.so.6 is missing...
    – zb226
    Oct 28, 2022 at 8:17

I have the same error. Just install the missing libxx package. You saw the error remains, probably because another libxx package is missing, and you need to continue install the new package. That's what I did.

  • Can you share the complete command? Oct 26, 2022 at 13:01
  • I can't reproduce, so I can't give you the exact package name. But the main idea is, if you successfully installed libxt6 using sudo apt install libxt6 then run VBoxClient --version again, the error message should be different. In my case it's another lib-something package missing, so I just kept installing the next missing one :)
    – Marvin Xu
    Oct 27, 2022 at 6:47
  • Did you read the UPDATE section in my post? Oct 27, 2022 at 20:42
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 3, 2022 at 12:56
  • Based on your comment beblow @zb226 's answer, you clearly didn't pay attention to the error message
    – Marvin Xu
    Nov 4, 2022 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.