1

I'm running Xubuntu 22.04, pretty much all stock, although it has been upgraded in place over 8 years and has accumulated a certain amount of cruft. I have a few Windows key + shortcuts set up, e.g. Windows + E to launch Thunar.

For a long time I was frustrated that I couldn't just press the Windows key by itself to open the Whisker menu, so I could quickly search for applications by name. I know that there are various guides online about how to do that, but all the ones I've found rely on mapping the Windows key via the XFCE keyboard shortcuts settings, which conflicts with Windows + other key combos. By this I mean, if I map the Windows key to the Whisker menu and Windows + E to Thunar, then when I press Windows + E, both actions occur: Thunar opens, but the Whisker menu pops up as well. Also, the Windows + letter combo works with both the left and right Windows keys, whereas the Whisker menu only pops up when I press the Windows key on the side I originally defined the shortcut on. In the settings, this shows as Super L or Super R, rather than just Super. I also use ibus-unikey with Windows + Space to switch keyboard layouts, which stops working completely if I map the Windows key to open the Whisker menu.

When Xubuntu 22.04 came out, I was surprised and pleased to see that I could press either Windows key by itself, and the Whisker menu would pop up. I didn't have to change anything with my keyboard shortcut settings, and it didn't conflict with my existing Windows + letter combos.

Sadly, a few days ago it stopped working again. I didn't knowingly change anything. I did clean out some packages that I thought were unused, and I regularly install updates from the Canonical repositories, but that's it. I'm wondering if I accidentally uninstalled an optional package that implements this behaviour, or if the new feature was just reverted upstream. It's not the end of the world, I managed for years without it, it's just a bit disappointing as it was working and I was using the feature a lot when it did! Any ideas on what's changed here?

1 Answer 1

1

Okay, I'm an idiot! I'm going to post this answer up here in case it helps anyone else. The feature I was after is provided by a package called xcape, which I don't remember installing or configuring, but judging by the logs in /var/log/apt/ I removed earlier this week because I didn't think it was doing anything.

I installed xcape and then ran the command /usr/bin/xcape -e 'Super_L=Control_L|Escape;Super_R=Control_L|Escape'. Ctrl + Esc is the default XFCE shortcut to xfce4-popup-whiskermenu, the main application menu. Once that was done, I verified that the Windows keys opened the application menu, and didn't interfere with my other Windows key shortcuts. After that I set a custom startup and session rule to launch this command on every login. Problem solved!

1
  • Cool, thanks for this tip. I noticed that it seemingly worked by default on Jammy and then stopped in Kinetic, just as you described, so I don't think you accidentally removed it yourself.
    – SuperDisk
    Jul 2, 2023 at 19:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .