I'm using Gnome 3 and proprietary Nvidia drivers. I have tried to set in nvidia-settings my external monitor to be "above" my main one (it's a laptop). However, when I try to drag a window up from the main display to the external one, it gets stuck and can't move past a certain point. Trying to maximize it changes its decoration so it looks maximized (i.e. no borders, etc), but its size or position doesn't change.

Now, if I set my external monitor to be "to the left" of the main one, it works, which is why I'm suspecting this is a Gnome issue, not an Nvidia one.

Anyone know how to fix this?

Update: some versions:

  • Gnome:
  • Nvidia: 280.13

Update 2: I can see that Gnome 3.4 is out, and among the release notes is better external monitor support. However, they only mention a small fix that is unrelated to my problem. Can anyone with Gnome 3.4 and access to an external monitor please test this out and tell me if it works? I don't want to go through the hassle of upgrading my Ubuntu installation unless I know for certain it's going to fix the problem.

  • Have you checked nvidia-settings ?
    – pl1nk
    May 31, 2012 at 1:44
  • Yes, that's how I set up the monitors.
    – Felix
    May 31, 2012 at 7:58

3 Answers 3


I will conclude that this is a Gnome bug (which I have filed), since this works in Unity. Also, I have tried using the open source nouveau drivers (which properly support xrandr), and the same thing happens.

  • Have there been any update on this bug? It's still present in Cinnamon, Gala and all the other mutter based managers. ( Using mint 14. ) Jan 7, 2013 at 17:03
  • Well, the bug is still open, I guess you can read the comments on it for updates.
    – Felix
    Jan 8, 2013 at 7:52

have a similar setup and therefore issue here but: if I get to get the external (upper) monitor as main one with the top panel than everything works fine. The downside is the process how to get the upper monitor to be the main one. For me, it takes a couple of active/deactive apply reapply... actions in nvidia-settings tool. Have not found any determinism on that one.

also to mention, at work I have Intel hardware and multimonitor-support works without issues.

thus it might be a gnome issue with how nvidia does its multimonitor-support?

  • I also achieved this by first deactivating my lower (built-in) display and then reactivating it again from "Displays" window.
    – JussiR
    Feb 6, 2014 at 10:15

I've found a solution for it... disable sticky edges in displays settings

  • On version 280.13???
    – Fabby
    Jan 29, 2016 at 21:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .