37

When my screen is locked and I then reawaken it, by moving the mouse or pressing the keyboard, the password entry screen appears. How can I change the amount of time that is taken before the password entry screen turns off?

To be specific:

  • I lock my screen Ctrl+Alt+T
  • Screen goes blank
  • Move mouse to bring up login screen
  • If I do nothing else the screen turns off again after 1 minute

In my Brightness and Lock settings I have the screen set to turn off and lock after 10 minutes, but I can't see a setting to determine how long it takes for the screen to turn off after the lock screen has been woken. It seems to be set to 1 minute by default, can this be increased/reduced?

enter image description here

  • May I know why do you want to change that option? – Khurshid Alam Jul 7 '13 at 13:36
  • I am about to go back to 13. I can't find a way to keep the machine from locking itself about every ten minutes. I am so over it. – user293278 Jun 13 '14 at 16:26
  • Not sure but this might be some of your help [ How to adjust screen lock settings on Linux desktop ](xmodulo.com/control-screen-lock-settings-linux-desktop.html) You might need to install dconf-editor – Prabhat Kumar Singh Jan 9 '15 at 10:58
  • 2
    @KhurshidAlam, May I answer for the asker? For example, when you work in two environments in one computer - Windows as a host machine and Ubuntu in VM. So sometimes Ubuntu locks your session when it is not desirable. – Green Aug 13 '15 at 3:46
  • A maximum of 15 minutes before the screen blanks isn't a very long time. Would really like to see a 30 minutes or even 60 minute option. It's very annoying when the screen begins to blank in the middle of a video. – Matt Mar 7 '18 at 1:54
14

Ubuntu 17.04 and earlier (Unity)

Open System Settings, click Brightness & Lock and select a value for the screen turn off option, Turn screen off when inactive for:

screenshot

Choose your time delay in the drop-down menu.

Ubuntu 17.10+ (Gnome Shell)

Check this question.

  • 9
    this doesn't affect the length of time that the password entry screen appears for – coversnail May 28 '12 at 15:42
  • How do I open System Settings? Can I script such a change with dconf? – René Nyffenegger Feb 12 '18 at 12:51
8

You can not do that anymore in Gnome3.

In gnome2 you can change lock-screen timeout from gnome-screensaver settings.But In Gnome 3.2, gnome-screensaver doesn't exist, and screen locking is part of Gnome Shell.

They have reimplement some function, but not all. On Ubuntu you can access all power-related settings with dconf-editor from org.gnome.settings-daemon.plugins.power.

OR

You can use x-screensaver as described here:

How can I change or install screensavers?

2

Settings -> Power -> disable dim screen when inactive & set blank screen to never

  • 2
    Welcome to Ask Ubuntu! Whilst this may answer the question it is not quite clear what this setting does exactly. Please elaborate your answer adding explanations. – dessert Nov 26 '17 at 16:33
0

Just had the same problem but could not resolve the issue with the answer provided by Kurshid Alam. On Gnome 3.28 using dconf-editor:

The screen saver turns on automatically when the session is considered idle

org . gnome . desktop . screensaver . idle-activation-enabled

The easiest way to delay the screensaver is to increase the time limit for idle

org . gnome . desktop . session . idle-delay

Or using terminal

gsettings set org.gnome.desktop.session idle-delay $((15*60)) && \
gsettings set org.gnome.desktop.screensaver lock-delay 0 && \
gsettings set org.gnome.desktop.screensaver lock-enabled true

Beware of possible impacts on laptop battery charge due to other services affected by the idle status.

-3

Press the windows button to get the unity search, then type lock in the search bar. Open brightness and lock and change the timeout.

  • 1
    this doesn't affect the length of time that the password entry screen appears for – coversnail May 28 '12 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.