0

"Solved" by upgrading from 20.04 to 22.04

I have tried all the suggested solutions,

sudo apt-get remove --purge libreoffice*
sudo apt-get update
sudo apt-get install libreoffice
sudo apt-get install libreoffice-plasma
sudo apt-get clean
sudo apt-get autoremove 

including in different, logically correct sequences.

$ dpkg -l | grep libreoffice
$ 

$ sudo apt-get install libreoffice Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

 libreoffice : Depends: libreoffice-base but it is not going to be installed
               Depends: libreoffice-calc but it is not going to be installed
               Depends: libreoffice-core (= 1:6.4.7-0ubuntu0.20.04.4) but it is not going to be installed
               Depends: libreoffice-draw but it is not going to be installed
               Depends: libreoffice-impress but it is not going to be installed
               Depends: libreoffice-math but it is not going to be installed
               Depends: libreoffice-report-builder-bin but it is not going to be installed
               Depends: libreoffice-writer but it is not going to be installed
               Depends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed
               Recommends: libreoffice-gnome but it is not going to be installed or
                           libreoffice-plasma but it is not going to be installed
               Recommends: libreoffice-nlpsolver but it is not going to be installed
               Recommends: libreoffice-report-builder but it is not going to be installed
               Recommends: libreoffice-script-provider-bsh but it is not going to be installed
               Recommends: libreoffice-script-provider-js but it is not going to be installed
               Recommends: libreoffice-script-provider-python but it is not going to be installed
               Recommends: libreoffice-sdbc-mysql but it is not going to be installed
               Recommends: libreoffice-sdbc-postgresql but it is not going to be installed
               Recommends: libreoffice-wiki-publisher but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

As requested, here the additional outputs

$ sudo apt update
Hit:1 http://de.archive.ubuntu.com/ubuntu focal InRelease
Get:2 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Hit:3 http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu focal InRelease
Get:4 http://de.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:5 http://de.archive.ubuntu.com/ubuntu focal-backports InRelease [108 kB]
Get:6 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [40,7 kB]
Get:7 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [77,3 kB]
Get:8 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2.464 B]
Fetched 456 kB in 1s (593 kB/s)  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

$ apt-cache policy libreoffice-core
libreoffice-core:
  Installed: (none)
  Candidate: 1:6.4.7-0ubuntu0.20.04.4
  Version table:
     1:7.3.6-0ubuntu0.22.04.1~bpo20.04.1 100
        100 http://de.archive.ubuntu.com/ubuntu focal-backports/main amd64 Packages
     1:6.4.7-0ubuntu0.20.04.4 500
        500 http://de.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages
     1:6.4.2-0ubuntu3 500
        500 http://de.archive.ubuntu.com/ubuntu focal/main amd64 Packages

And here is, from the logs, when it all happened (end of previous, normal, command the day before, cut intermediate lines):

Processing triggers for man-db (2.9.1-1) ...
Log ended: 2022-09-28  09:45:10

Log started: 2022-09-29  10:26:41
(Reading database... 100%
(Reading database ... 330469 files and directories currently installed.)
Removing libreoffice-wiki-publisher (1.2.0+LibO6.4.7-0ubuntu0.20.04.4) ...
Removing libreoffice-sdbc-hsqldb (1:6.4.7-0ubuntu0.20.04.4) ...
Removing libreoffice (1:6.4.7-0ubuntu0.20.04.4) ...
...
Removing libreoffice-core (1:6.4.7-0ubuntu0.20.04.4) ...

The ubuntu version is Ubuntu 20.04.5 LTS

I haven't changed anything, not added anything. For the last months only $ sudo apt-get -y update && sudo apt-get -y dist-upgrade

Here we are off backports:

$ cat sources.list | grep back
## Also, please note that software in backports WILL NOT receive any review
## deb http://de.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
$ sudo apt update
Hit:1 http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu focal InRelease
Hit:2 http://de.archive.ubuntu.com/ubuntu focal InRelease
Get:3 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:4 http://de.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:5 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [40,7 kB]
Get:6 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [77,3 kB]
Get:7 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2.464 B]
Get:8 http://de.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [278 kB]
Get:9 http://de.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [391 kB]
Get:10 http://de.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [944 B]
Fetched 1.018 kB in 1s (1.064 kB/s)        
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
$ sudo apt autoremove libreoffice
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'libreoffice' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$ sudo apt install libreoffice
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libreoffice : Depends: libreoffice-base but it is not going to be installed
               Depends: libreoffice-calc but it is not going to be installed
               Depends: libreoffice-core (= 1:6.4.7-0ubuntu0.20.04.4) but it is not going to be installed
               Depends: libreoffice-draw but it is not going to be installed
               Depends: libreoffice-impress but it is not going to be installed
               Depends: libreoffice-math but it is not going to be installed
               Depends: libreoffice-report-builder-bin but it is not going to be installed
               Depends: libreoffice-writer but it is not going to be installed
               Depends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed
               Recommends: libreoffice-gnome but it is not going to be installed or
                           libreoffice-plasma but it is not going to be installed
               Recommends: libreoffice-nlpsolver but it is not going to be installed
               Recommends: libreoffice-report-builder but it is not going to be installed
               Recommends: libreoffice-script-provider-bsh but it is not going to be installed
               Recommends: libreoffice-script-provider-js but it is not going to be installed
               Recommends: libreoffice-script-provider-python but it is not going to be installed
               Recommends: libreoffice-sdbc-mysql but it is not going to be installed
               Recommends: libreoffice-sdbc-postgresql but it is not going to be installed
               Recommends: libreoffice-wiki-publisher but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt install libreoffice=6.4.7-0ubuntu0.20.04.4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '6.4.7-0ubuntu0.20.04.4' for 'libreoffice' was not found
$ sudo apt install libreoffice=6.4.7-0ubuntu0.20.04.5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '6.4.7-0ubuntu0.20.04.5' for 'libreoffice' was not found
$ 

What can I do to remedy the situation, please?

3
  • Edited as requested. Thanks so far!
    – udippel
    Commented Sep 30, 2022 at 14:31
  • Having the version of Ubuntu in the question is often helpful and should always be stated.
    – David
    Commented Sep 30, 2022 at 14:58
  • Please don't put SOLVED in the question title in this site. You can always use the Answer Your Own Question button.
    – user68186
    Commented Oct 2, 2022 at 13:25

1 Answer 1

0

Answer to self: "Solved" by updating Kubuntu from 20.04 to 22.04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .