0

I read through quite some forums, but none of the mentioned solutions could help me.

I have a USB (64GB), when I plug it in, it is recognized by lsusb (/dev/sdb, no /dev/sdb1, hence I can't mount it), dmesg, lsblk, etc. Initially it gave an error in dmesg when plugging it in, but after some research I had to make a change for high speed USB devices with: echo -1> /sys/module/usbcore/parameters/autosuspend. After checking if that worked, I made it permanent by creating a file usbcore in /etc/modprobe.d with the following line: options usbcore autosuspend=-1.

I checked with a 32GB and 128GB USB, which work fine.

I am using Ubuntu 22.04 on a Toshiba TECRA Z50-A PT544E-011005DU. See below the results of the various things I tried:

lsusb: lsusb output

lsblk (notice size 0): lsblk output

sudo fdisk -l (it doesn't show here): fdisk output

dd if=/dev/null of=/dev/sdb: dd output

dmesg: dmesg output

sudo dmesg | grep sdb: dmesg grep sdb output

sudo parted -l: parted -l output

I tried mkusb as well, to remove the first bit and I tried to whipe the drive completely. Both give the message that media is not found.

gparted doesn't show the drive in the first place.

This is the information which was requested for other questions. Let me know if you need more information.

I hope someone has any more ideas... or maybe my USB is just dead... :-)

1
  • It seems the drive is as good as dead. Commented Sep 29, 2022 at 17:16

1 Answer 1

0

according to: https://unix.stackexchange.com/questions/34121/how-to-salvage-an-unreadable-usb-flash-drive the connector(male or female) could be corrupted(bad contact).

Have you tried another port(maybe obvious)?

Do other USB-Sticks work properly?

If none of this helps your drive is propably dead.

2
  • Yes, forgot to mention I tried other ports as well. As I mentioned, other sticks do work. So I guess I'll have to burry it :-) Thanks! At least it seems I tried what I could. :-)
    – Dennis
    Commented Sep 29, 2022 at 18:08
  • Thanks for the article. It is a bad contact indeed! In the article, the mentioned, when they press it down, it works and so does it with me! :-) I spent quite some time on it and it is just this... :')
    – Dennis
    Commented Sep 29, 2022 at 18:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .