3

Ubuntu 20.04 reaches end of standard support in April 2025 and so has some life left in it yet. At present (Sept 2022), Ubuntu provides php 7.4 as the default php package for Ubuntu 20.04 and doesn't provide any php8.0 or php8.1 packages. php itself will only provide security support for php 7.4 until 28 November 2022, although Ubuntu may choose to provide security support beyond that date.

To aid planning, is someone able to say:

  1. when Ubuntu will cease to provide security support for php 7.4,
  2. if and when php 8.0 or 8.1 packages will become selectable alongside php 7.4, and
  3. when php 7.4 will be dropped completely in favour of php 8.x

on Ubuntu 20.04?

Thanks.

1

1 Answer 1

6

Never going to happen unless you do it yourself. 20.04 will stick to 7.4 with security updates. From StableReleaseUpdates:

Once an Ubuntu release has been completed and published, updates for it are only released under certain circumstances, and must follow a special procedure called a "stable release update" or SRU.

Users of the official release, in contrast, expect a high degree of stability. They use their Ubuntu system for their day-to-day work, and problems they experience with it can be extremely disruptive. Many of them are less experienced with Ubuntu and with Linux, and expect a reliable system which does not require their intervention.

Stable release updates are automatically recommended to a very large number of users, and so it is critically important to treat them with great caution. Therefore, when updates are proposed, they must be accompanied by a strong rationale and present a low risk of regressions.

"It's just a one-line change!"

Even the simplest of changes can cause unexpected regressions due to lurking problems:

...

High-impact bugs

Stable release updates will, in general, only be issued in order to fix high-impact bugs. Examples of such bugs include:

...

See the link for more on this.

The packages list shows:

bionic (18.04LTS) (php): 1:7.2+60ubuntu1: all
focal (20.04LTS) (php): 2:7.4+75: all
impish (21.10) (php): 2:8.0+82~0build1: all
jammy (22.04LTS) (php): 2:8.1+92ubuntu1: all
kinetic (php): 2:8.1+92ubuntu1: all

The version is shown behind the : so for 8.0 you need at least 22.04 (assuming LTS only)

You can install php8 yourself if you really want it but I would advice upgrading to 22.04.

If you want to be independent of php used in Ubuntu you can also install a tarball in /opt and have that migrate through different versions (you can have a setup like /opt/php/, /opt/php-7.4. /opt/php-8.1/ where /opt/php/ and put a symlink in /usr/bin/ that points to /opt/php and that one holds a symlink to the active php version in the 2 other directories.

15
  • +1 Migrating to 22.04 should be safer and easier for most folks than fiddling with PPAs or upstream repos or hoping-for-a-verion-bump or other methods.
    – user535733
    Sep 29 at 14:07
  • Most of this is not relevant to the question I asked. I don't want to install php myself. Have you got a source/evidence for the two claims "Never going to happen unless you do it yourself" and "20.04 will stick to 7.4 with security updates"? I guessed and hoped that that would be the case when I asked the question, but is there any official documented plan? The two things I want to avoid are a) 7.4 being dropped without being prepared for it and b) security support for 7.x being ceased. As @user535733 notes, version bumps do happen.
    – Fred
    Sep 29 at 15:36
  • 1
    @Fred I'm a member of the Ubuntu Server Team as a volunteer, and a member of the Ubuntu Core Dev team, and I can affirm that Rinzwind's answer is the canonical answer from the Server Team and Ubuntu Release Teams about whether we're version-bumping PHP on an already stable release. In case you want stronger affirmation by someone who regularly does Ubuntu development with the hats to back them up.
    – Thomas Ward
    Sep 29 at 16:48
  • 1
    @LesterPeabody the Security team will likely backport out of band patches in for the unsupported PHP versions themselves, thereby adapting patches where they need to, and enlisting other Canonical PHP/Server developers to assist where needed. Exact documentation beyond that statement is nonexistent.
    – Thomas Ward
    Sep 29 at 19:15
  • 1
    @Fred no, "advance warning" of updates are not announced they just happen. Same with security patches. Changes for PHP versions per release and what version of PHP is in each release are in each Ubuntu release's release notes.
    – Thomas Ward
    Oct 3 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.