4

I have Xubuntu version 22.04.1. This has started to happen to me only recently, and is annoying as heck: pressing the Super (Windows) key minimizes all the windows to show the bare desktop. (Pressing it again restores the windows.) How do I stop the Super key by itself having an effect?

It is only the left-side Super key that has this effect. Pressing the right-side Super key has no effect. I have the Swedish+Finnish keyboard, in case that makes any difference.

In Settings => Window Manager => Keyboard, I have no action mapped to the Super key, and the action "Show desktop" is mapped to Ctrl+Escape. I tried remapping the action to another key, then deleting the mapping and remapping, but none of that helped.

In Settings => Keyboard => Application Shortcuts, I have no action mapped to the Super key, nor is there a definition for a command that would show the desktop.

I have never attempted to map an action to the Super key by itself, nor do I want to.

Question How do I disable the Super key? has answers relevant only to Ubuntu and the Unity desktop. (Unity was the reason I switched to Xubuntu.)

Edited on 2022-10-01 to add:

The output of localectl is:

 System Locale: LANG=en_US.UTF-8
                LANGUAGE=en
                LC_NUMERIC=en_GB.UTF-8
                LC_TIME=en_GB.UTF-8
                LC_COLLATE=en_GB.UTF-8
                LC_MONETARY=en_GB.UTF-8
                LC_PAPER=en_GB.UTF-8
                LC_NAME=en_GB.UTF-8
                LC_ADDRESS=en_GB.UTF-8
                LC_TELEPHONE=en_GB.UTF-8
                LC_MEASUREMENT=en_GB.UTF-8
                LC_IDENTIFICATION=en_GB.UTF-8
     VC Keymap: n/a
    X11 Layout: fi
     X11 Model: pc105

Edited on 2022-10-13 to add:

This is in reply to user Andra's suggestion to use screenkey. I installed it using apt, ran it, and started pressing keys. When I pressed either the the left-hand or the right-hand Super key (Super_L or Super_R) + m, screenkey displayed "Super+m". When I pressed and released the Super_R key, nothing happened, and screenkey displayed nothing. But: when I pressed and released the Super_L key, all the windows were minimized, as before, and screenkey displayed "Ctrl+Esc". (Pressing it again restores the windows.) As I mention above, the "Ctrl+Esc" shortcut is mapped to action "Show desktop" in Settings => Window Manager => Keyboard.

I then tried this: I remapped "Show desktop" to shortcut "Shift+Alt+F5". Now, when I pressed and released the Super_L key, screenkey again displayed "Ctrl+Esc", but there was no other effect. (Pressing Shift+Alt+F5 now did minimize the windows, and screenkey displayed "Alt+Shift+F5".)

I have no idea how the Super_L key came to be interpreted by the system as "Ctrl+Esc".

Edited on 2022-10-15 to add:

The output of setxkbmap -print -verbose 10 is:

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     fi
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+fi+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete" };
    xkb_compat    { include "complete" };
    xkb_symbols   { include "pc+fi+inet(evdev)" };
    xkb_geometry  { include "pc(pc105)" };
};

Edited on 2022-10-16 to add:

The output of xmodmap -pke | grep Super is:

keycode 133 = Super_L NoSymbol Super_L
keycode 134 = Super_R NoSymbol Super_R
keycode 206 = NoSymbol Super_L NoSymbol Super_L

Edited on 2022-10-19 to add:

The output of gsettings list-recursively | grep -i escape is:

org.gnome.desktop.wm.keybindings cycle-panels ['<Control><Alt>Escape']
org.gnome.desktop.wm.keybindings cycle-panels-backward ['<Shift><Control><Alt>Escape']
org.gnome.desktop.wm.keybindings cycle-windows ['<Alt>Escape']
org.gnome.desktop.wm.keybindings cycle-windows-backward ['<Shift><Alt>Escape']
org.gnome.mutter.wayland.keybindings restore-shortcuts ['<Super>Escape']
20
  • could you write the output of localectl plz?
    – Amirreza
    Oct 1, 2022 at 9:55
  • @Amirreza I've added the output to my question. Oct 1, 2022 at 16:57
  • 1
    I do not confirm your issue. On daily installation iso xubuntu-jammy, pressing Super_Left, opens application menu. To configure it, press right mouse btn on mouse icon -> Properties. Oct 5, 2022 at 19:10
  • @pasman pasmański I have another computer I've just installed Xubuntu 22.04.1 on, and I don't see this behaviour on that machine, either. So I must have done something to cause this to happen on the first machine; I just don't know what. If I figure it out, I'll add my own answer to this queestion. Oct 5, 2022 at 19:52
  • 1
    sorry, another Ubuntu version. Screenkey?
    – Andra
    Oct 10, 2022 at 16:24

1 Answer 1

0

The problem seems to be due to some sort of a bug with Xfce's keystroke mapping system. The solution was to clear, in Settings => Window Manager => Keyboard, my custom mapping of keystroke Ctrl+Esc to action "Show desktop".

I found out the following when configuring another laptop with Xubuntu 22.04 just installed. I was customizing the keystroke mappings (Settings => Window Manager => Keyboard). By default, the keystroke for "Show desktop" was "Super+D". Keystrokes Super_L+D and Super_R+D showed the desktop, as expected, and the key Super_L by itself showed the whisker menu (Xfce's equivalent to the Windows Start menu), which was unexpected.

I then changed the keystroke that maps to action "Show desktop" to Ctrl+Esc, as I had done on the laptop that first presented the problem. Immediately after this, keystroke Super+D did nothing anymore, as expected; keystroke Ctrl+Esc showed the desktop, as expected; and key Super_L by itself also showed the desktop, as certainly not expected, and which is the problem under discussion.

Clearing the mapping of keystroke Ctrl+Esc to action "Show desktop" resolved the problem. After this, Super_L did nothing anymore, whereas before I started manipulating the mappings, it showed the whisker menu, as mentioned. But I did not see an explicit mapping of Super_L to the whisker menu anywhere.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.