I've been trying to follow the directions listed here to create an installer usb image from an iso file using gnome-disks 'Restore Disk Image' option as detailed in the directions. However, the usb created is still not bootable.

I noticed on an image that was bootable, there was an efi partition listed at the beginning of the usb drive after it was flashed. However, with the non booting image, the efi partition is at the end of the drive.

Am I missing something? The directions seem straight forward enough and I've tried and retried them multiple times and still, no luck. Any one have any idea what could be wrong?

  • What version of Ubuntu are you using?
    – David
    Sep 26, 2022 at 5:01
  • ubuntu.com/tutorials/… ubuntu.com/tutorials/… ubuntu.com/tutorials/… The ISO you're using will dictate what gets written to the boot-media you'll install from, and you've provided no specific details; I'd suggest following official Ubuntu tutorials for Ubuntu's ISOs (as you gave no product details; use other tutorials if they don't match your unstated product)
    – guiverc
    Sep 26, 2022 at 6:52

1 Answer 1


It turns out the issue was the usb thumb drive. Based on how the image itself was created, I think the maximum size of the thumb drive is 8gb. Once I swapped the thumb drive, everything worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.