I have an ASUS Zenbook OLED with a trackpad.

Even though this trackpad is fine, and mouse pointer movement is a good speed, the two-finger scroll is just too darn fast.

In the settings app, I can only set the pointer movement speed, not the scroll speed.

In the gnome-tweaks app, there is nothing to set the scroll speed either.

The only thing I could find is a hack that is far too drastic. (preloading a lib, and on-the-fly hacking the input events.)

A 'libinput measure' run was of no help.

I cannot find a libinput quirk attribute that would let me control scroll speed.

OS: Ubuntu 22.10

Desktop: Wayland

libinput: 1.21.0

laptop: ASUS ZenBook UX325EA

$ sudo libinput --list-devices
Device:           ASUE140A:00 04F3:3134 Touchpad
Kernel:           /dev/input/event6
Group:            6
Seat:             seat0, default
Size:             129x64mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Disable-w-trackpointing: enabled
Accel profiles:   flat *adaptive
Rotation:         n/a

3 Answers 3


I have an Ubuntu 22.04 and I got it to work in chrome. got to chrome://flags/ search Windows Scrolling Personality and enable it.


I've given up on getting this to work.

Note, although I am on Ubuntu 22.10, the same issue is present on older Ubuntu versions too.

I did find a workaround by doing the scrolling per app if the app has a setting for it.

For instance, Firefox:

Go to URL about:config

Accept the risk and continue.

Then search for mousewheel.default and set the multiplier values to something lower.

enter image description here

  • Thank you for the work around. I can't understand why Ubuntu and other distros aren't fixing this issue.
    – Mihir
    Jan 3 at 15:18
  • How do we do it for Brave and other chromium based browsers?
    – Mihir
    Feb 26 at 15:07

EDIT: I'm reading by now that synaptic might not be the best solution but libinput

you might disable wayland and use xinput instead by editing the /etc/gdm3/custom.conf file, you can do a sudo nano /etc/gdm3/custom.conf and uncomment the line that has WaylandEnable=false and then restart.

Once restarted you should be able to change xinput properties. List your devices withxinput list and change the property "Synaptics Scrolling Distance":

xinput --set-prop <id> 'Synaptics Scrolling Distance' -120 -120

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.