2

I am using Teamviewer to gain remote control to my Ubuntu wipe server, but I am getting this message that I need to accept the connection otherwise it will not get any connection. I want to make sure that I always can make a connection without needing to accept the connection.

Screenshot of the message:

Screenshot of the message

7
  • What version of Ubuntu are you using? This sounds like a good question for the people that make the Teamviewer app.
    – David
    Sep 23, 2022 at 9:33
  • I am using version 22.04.1, I don't think so because I have the same probleem with anydesk. Sep 23, 2022 at 9:57
  • This is a feature of TeamViewer and Anydesk. You can disable it in the app's settings. Look in the security section of the setting. If you still can't do it, I can write an answer for Anydesk. I don't have TeamViewer.
    – user68186
    Sep 23, 2022 at 13:16
  • If you can feel free to tell me how to do in anydesk and i wil look in to it Sep 23, 2022 at 14:03
  • 1
    @MarcoDoornbos please alter the q to include anydesk and make it more generic. The answer added for anydesk is now NOT an answer to the q but an answer to a comment and as such off topic.
    – Rinzwind
    Jan 21, 2023 at 14:37

2 Answers 2

2

This is probably caused by having Wayland enabled.

Method to switch from Wayland to X (to make Firefox work)

Edit the configuration file,

sudo nano /etc/gdm3/custom.conf

to uncomment [remove # from] the line containing

WaylandEnable=false

save the file (ctrl + x and after that y ('yes') or another key for non-English and finally Enter) and reboot.

0

AnyDesk

Download and install AnyDesk in both the main computer and the laptop. The same software works as a client and a server. The installation process will add its PPA to the list of repositories, and AnyDesk will be updated like most Ubuntu software.

Unattended Access

By default AnyDesk does not allow unattended access. That is, when someone tries to remotely access your main computer using AnyDesk you will have to accept the connection from within the main computer. This is not possible in your use-case.

Open AnyDesk on your main computer. Click on the "hamburger" menu icon on the top left corner and click on Settings

Go to the Security tab on the right panel of the Settings window.

enter image description here

You have to click on the Unlock Security Settings and enter your password to get this page to work. Once unlocked you will see a page like this:

enter image description here

Check the Enable Unattended Access box and set a password. If you want you can also enable Two Factor Authentication. This will require installing an app on your phone that can generate two factor authentication tokens, such as Google Authenticator, or Authy.

Finally, note down the AnyDesk ID number of your main computer. You can see it under the This Desk heading on the left panel.

enter image description here

You can close the Anydesk app on the Main computer. The app need not be open for remote access.

On your laptop open AnyDesk and enter the ID number of the main computer in the Remote Desk box on the left panel and click on the Play icon ▶.

Hope this helps

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .