Let's see, I cannot log in in Lubuntu 12.04. On the shell I get when typing startx:

  _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener()  failed
  _XSERVTransMakeA11C0TSServerListeners: server already running

  Fatal server error:
  Cannot establich any listening sockets - Make sure an X server isn't already running

 Please also check the log file at "/var/log/Xorg.0.log" for additional information.  
 ddxSigGiveUp: Closing log
 Server terminated with error (1). CLosing log file

 Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyxinit: giving up
 xinit: unable to connect to X server: Resource temporarily unavailable
 xinit: server error  

Before I had only read-right on the file-system with sudo autoremove I got my write-rights back. I removed the .Xauthority* files in /home/username. Still cannot login back

5 Answers 5


I found a solution for me: Well, I hope someone can use my answer:

I changed my password, reinstalled xserver-xorg by typing: sudo apt-get install --reinstall xorg

After a reboot it worked for me. Notice: I removed the .XAuthority files in /home/username by: sudo rm /home/username/.XAuthority*

to get a shell try Strg-Alt-F1 when you turn on your computer. I actually got my write-rights back by using clear in recovery mode.

Hopefully, this answer can help others as well.

  • Worked for me as well. I'd spent the last hour removing Xauthority files and getting rid of xinitrc and reinstalling xorg and rebooting, but somehow doing it in this sequence worked.
    – Anubhav C
    Oct 15, 2013 at 15:37
  • Had a freeze after entering password on login screen, while being able to enter via ssh. Removing .Xauthority files worked.
    – Pafnucy
    Mar 21, 2020 at 23:18

I got this message too, in my case the X server was indeed already running, I just had to switch to terminal 7 (the first GUI terminal) by pressing CTRL + ALT + F7.


I had the same problem, but after 2 hours of search I ended up with x.org FAQ messages page, in that page explained to deal with these two errors like each others: 1 - "Server is already active for display 0" 2 - "Cannot establish any listening sockets..." It seems that X server is running, but you cannot just type startx -- :1 and start a new one, you should remove these two files:



and then start new X server on another display:

startx --:1

and then done! my screen back! I just tried to help here, for more information, this is the link that I found on www.x.org http://www.x.org/wiki/FAQErrorMessages/#index5h2


Did you "Make sure an X server isn't already running" by trying something like startx -- :1? Maybe a [g|x|light]dm process was already running and blocking DISPLAY :0.

  • I cannot tell you really whether that was a problem... Now everything is fine.. I put the solution in the edit, because I couldn't have answered it myself, since I'm a newbie in the forum. Jun 15, 2012 at 11:57

I get similar message to run

Xorg -configure

You test free space disk:

df -Th

For my case was this and if it has 100% You can get free space disk width

apt-get clean
  • 2
    It isn't very clear how this is an answer. Could you clarify that bit? Thanks.
    – Seth
    Jul 31, 2014 at 21:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .