I have window 7 64 bit Lenovo i7 with 8gb ram and 160gb ssd. I have virtual box version 4.1.16 installed (most latest to my knowledge)

I want to install ubuntu 12.04 as a guest inside of virtualbox. I have tried a couple of times now. It installs and "works" but the cpu in the guest os with no applications running is between 30% and 100%. The host machine is running without any slow downs. I have tried all sorts of different settings from within ubuntu and on virtualbox. But ubuntu continues to race.

Has anyone experienced this? Any help would be appreciated.


  • Did you install the virtual guest extensions inside your vm? Your system seems to have more than enough power to have a better expirence. You may also try to enable multi processing in the options. – gemue2010 May 28 '12 at 4:52
  • I have tried giving it 2 cpu's then virtualbox requires io apic and it does boot for me with that setting checked. I just set it to unity 2d and that seems to be a little better but still cpu is running. – bytebender May 28 '12 at 5:34
  • 2
    Are you saying Ubuntu's system tools are reporting 30-100% usage of the CPU or that task manager tells you that the virtualbox application running Ubuntu is using 30-100% of the CPU from the host? – Bruno Pereira May 28 '12 at 6:23

So my issues appears to have been being caused by NOT running in ubuntu 2d and a setting in the bios (VT-x). Once I changed the setting in the bios. The performance became drastically better and I also was then able to allow for 2 cpu's.

Thanks for all of your help.

  • did you enable or disable the VT-x setting to increase performance? – jeroen Jun 17 '12 at 19:49
  • enabled them in the bios – bytebender Mar 24 '13 at 15:00

I have experienced the same problem.

⠀Host: Ubuntu 14.10 (64-bit)
⠀Guest: Windows 7 (64-bit)

Even with the virtualization turned on in host BIOS the CPU load was constantly around 40-50% in guest idle state.

What helped me was installing Guest Addition with Direct 3D support (you need to do that in safe mode) and turning on the host I/O Cache of the SATA controller.

So my current settings are:

⠀Base memory: 4096 Mb (8192 Mb total host memory)
⠀Processor: 6 CPUs (of host 6 CPUs)
⠀PAE/NX: Enabled
⠀VT-x/AMD-V: Enabled
⠀Nested Paging: Enabled

⠀Video memory: 128 Mb
⠀3D Acceleration: Enabled
⠀2D Acceleration: Enabled

Works like a charm! Virtual Box Version: 4.3.18_Ubuntu r96516

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.