It does not matter what kind of DVD I try to play on either my DVD-ROM or my DVD-R/RW I get the same error message from VLC media player.

I have tried all disc device options. This is the error message:

Playback failure:
DVDRead could not open the disc "/dev/dvd".
Your input can't be opened:
VLC is unable to open the MRL 'dvd:///dev/dvd'. Check the log for details.
  • Can you provide the log?
    – Ravi
    May 28 '12 at 10:44
  • Sounds like the /dev/dvd symbolic link is not correctly set up. Consider finding out the device name of the drive, and tell that to vlc instead. May 28 '12 at 11:30
  • Show us the output of these 2 commands. mount|grep ^'/dev' sudo lshw -C disk
    – cokedude
    Jun 4 '12 at 21:47

Do you have all the codecs installed?

If not add the medibuntu repository. Open a terminal and paste the following

sudo -E wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update

Then run

sudo apt-get update && sudo apt-get install libdvdcss2

Otherwise it might be a hardware problem. Hopefully someone else can step in and assist. Good luck.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.