9

I have a strange problem that my mouse keeps selecting everything I point to. For example, if I open Rhythmbox, then at the top of the screen there is a text which says which song is playing. If I move my mouse over this text, then it will select this text; but I am not clicking.

This behaviour does not happen in all programs. For example in Firefox I have no problem at all. Maybe it is Gtk related? Nautilus also behaves strangely; I cannot open files by clicking on them, I have to select and make a box around the file and then press enter to open it. If I click, then nothing happens. Similar problems also happen with other Gtk software.

I think the problem might be related to touchscreen issues (I have a touchscreen). I run Gnome 3 on Ubuntu 12.04. I have a HP touchsmart 610 desktop computer. Any help is greatly appreciated.

UPDATE: I just did a fresh reinstall, and I am 90% certain that it is related to the touchscreen drivers. Here is what happens when I reinstall. At first boot, so exactly after install, everything works fine, except the touchscreen: The touchscreen does not respond. I update ubuntu, because I installed from an old CD (CD with ub. 12.04). Then on next reboot I have touchscreen working , but the working touchscreen comes together with the mouse selecting everything on its own.

SECOND QUESTION: Would anybody know how I could figure out what those touchscreen drivers are (so that I can disable them) ?

  • Try hitting escape a few times, our tapping your touchpad. I've had this at times when using my laptop with the touchpad-type mouse. Unfortunately, this may just be a bug. Try to find out if you can reliably reproduce it. – belacqua May 27 '12 at 20:19
  • it is easy to reproduce, because it always happens with no exception. Go into the program, and Gnome will think I have my mouse clicked and select things I move over. – mnr May 28 '12 at 8:52
  • You might try looking on launchpad for a similar bug. (You can see my profile for the 'how to report a bug' link, as well.) – belacqua May 29 '12 at 18:36
4

There is a bug in X and it's already reported. Sadly it took a while for them to realize that it's made by X.

| improve this answer | |
18

Touch your screen to make it stop.

I have the same problem on a touchscreen machine. It just happened now, and I decided to see if someone offered a solution. @mnr's mention that it might be touchscreen-related made me try: Touching the screen made the mouse stop auto-highlighting.

| improve this answer | |
  • 3
    I used to get so frustrated, I'd save everything and reboot to resolve this issue! I finally found this, and yes, touching the screen "fixes" the problem (In Ubuntu 18.04 with Dell XPS 9560). Thanks, @Rasmus! – mightypile Oct 21 '18 at 2:52
  • 1
    I was suspecting a hardware issue on my 5 year old Lenovo Y70-70 Touch and after so many annoying reboots you saved my day, @Rasmus – Anbu Agarwal Apr 5 at 8:44
7

Got to System Settings -> Universal Access -> Pointing and Clicking:

enter image description here

Make sure you have not activated Hover Click

| improve this answer | |
  • thanks for the idea, unfortunately hover click is not enabled. – mnr Sep 29 '12 at 9:33
  • so this is not the issue. I think it has something to do with touchscreen drivers – mnr Sep 29 '12 at 9:34
  • @meneer: driver or even hardware issue seems likely. I made the answer for people that may come here from the title ;) – Takkat Sep 29 '12 at 10:32
  • Hi Takkat. I just did a fresh reinstall, and I am 90% certain that it is related to the touchscreen drivers. Here is what happens when I reinstall. At first boot, so exactly after install, everything works fine, except the touchscreen: The touchscreen does not respond. I update ubuntu, because I installed from an old CD (CD with ub. 12.04). Then on next reboot I have touchscreen working , but the working touchscreen comes together with the mouse selecting everything on its own. – mnr Oct 9 '12 at 5:36
  • @Takkat: I had a similar problem in Ubuntu 16.04, and this solved my problem, thank you. – Navaro Oct 4 '16 at 22:32
1

In my case, it was my mouse cord on top of the touchpad the one created the mayhem. It took me a shameful time to figure this out...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.