0

The Lenovo Thinkpad X1 Extreme Gen 5 laptop v1.08 BIOS suspends successfully after closing the lid and appears to resume when opening the lid. However, no video is displayed. Instead, the LCD screen appears backlit, but black. I have tried to troubleshoot using all the Nvidia driver versions 470, 510 and 515. In addition, I have tried X.Org X server Nouveau combined with disabling Wayland in /etc/gdm3/custom.conf. I have also tried to disable the Nvidia suspend, hibernate, and resume services, all without the success of remediating the issue. I have also toggled Linux S3 Sleep in the BIOS settings to no avail. I have tried this all with the latest generally available kernel and the developer-enabled optional kernel below.

Any ideas? Thanks in advance.

Specs:

Lenovo Thinkpad X1 Extreme Gen 5
NVIDIA Corporation GA103M [GeForce RTX 3080 Ti Mobile] (rev a1)
Intel Corporation Alder Lake-P Integrated Graphics Controller (rev 0c)
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=22.04
DISTRIB_CODENAME=jammy
DISTRIB_DESCRIPTION="Ubuntu 22.04.1 LTS"
PRETTY_NAME="Ubuntu 22.04.1 LTS"
NAME="Ubuntu"
VERSION_ID="22.04"
VERSION="22.04.1 LTS (Jammy Jellyfish)"
Linux 5.15.0-48-generic #54-Ubuntu SMP Fri Aug 26 13:26:29 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
$cat /proc/driver/nvidia/version 
NVRM version: NVIDIA UNIX x86_64 Kernel Module  515.65.01  Wed Jul 20 14:00:58 UTC 2022
$nvidia-smi
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 515.65.01    Driver Version: 515.65.01    CUDA Version: 11.7     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   39C    P3    N/A /  N/A |      5MiB / 16384MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A      4822      G   /usr/lib/xorg/Xorg                  4MiB |
+-----------------------------------------------------------------------------+

$cat /sys/power/mem_sleep 
[s2idle]
$dmidecode -s bios-version
N3JET24W (1.08 )
$dmesg
[   70.088474] wlp0s20f3: deauthenticating from a5:e2:90:13:cf:06 by local choice (Reason: 3=DEAUTH_LEAVING)
[   72.602167] rfkill: input handler enabled
[   72.760707] PM: suspend entry (s2idle)
[   72.764050] Filesystems sync: 0.003 seconds
[   73.035394] Freezing user space processes ... (elapsed 0.004 seconds) done.
[   73.040015] OOM killer disabled.
[   73.040019] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[   73.041748] printk: Suspending console(s) (use no_console_suspend to debug)
[   74.705679] ACPI: EC: interrupt blocked
[  111.351101] ACPI: EC: interrupt unblocked
[  112.420887] nvme nvme0: 20/0/0 default/read/poll queues
[  112.437817] i915 0000:00:02.0: [drm] GuC firmware i915/adlp_guc_62.0.3.bin version 62.0 submission:enabled
[  112.437823] i915 0000:00:02.0: [drm] GuC SLPC: enabled
[  112.437825] i915 0000:00:02.0: [drm] HuC firmware i915/tgl_huc_7.9.3.bin version 7.9 authenticated:yes
[  112.438708] i915 0000:00:02.0: [drm] GuC RC: enabled
[  112.940361] OOM killer enabled.
[  112.940368] Restarting tasks ...
[  112.941913] mei_hdcp 0000:00:16.0-b638ab7e-94e1-4ea2-a552-d1c54b627f04: bound 0000:00:02.0 (ops i915_hdcp_component_ops [i915])
[  112.945309] done.
[  112.955862] thermal thermal_zone10: failed to read out thermal zone (-61)
[  113.010296] PM: suspend exit
[  113.863611] rfkill: input handler disabled
[  117.374757] wlp0s20f3: authenticate with a5:e2:90:13:cf:06
[  117.380684] wlp0s20f3: send auth to a5:e2:90:13:cf:06 (try 1/3)
[  117.455125] wlp0s20f3: authenticated
[  117.457852] wlp0s20f3: associate with a5:e2:90:13:cf:06 (try 1/3)
[  117.460849] wlp0s20f3: RX AssocResp from a5:e2:90:13:cf:06 (capab=0x1011 status=0 aid=4)
[  117.467092] wlp0s20f3: associated
[  117.522287] IPv6: ADDRCONF(NETDEV_CHANGE): wlp0s20f3: link becomes ready
[  121.535978] kauditd_printk_skb: 3 callbacks suppressed
[  121.535980] audit: type=1400 audit(1663205710.438:81): apparmor="DENIED" operation="capable" profile="/snap/snapd/16778/usr/lib/snapd/snap-confine" pid=3829 comm="snap-confine" capability=12  capname="net_admin"
[  121.535985] audit: type=1400 audit(1663205710.438:82): apparmor="DENIED" operation="capable" profile="/snap/snapd/16778/usr/lib/snapd/snap-confine" pid=3829 comm="snap-confine" capability=38  capname="perfmon"
[  121.822539] audit: type=1400 audit(1663205710.722:83): apparmor="DENIED" operation="capable" profile="/snap/snapd/16778/usr/lib/snapd/snap-confine" pid=3895 comm="snap-confine" capability=12  capname="net_admin"
[  121.822545] audit: type=1400 audit(1663205710.722:84): apparmor="DENIED" operation="capable" profile="/snap/snapd/16778/usr/lib/snapd/snap-confine" pid=3895 comm="snap-confine" capability=38  capname="perfmon"
[  128.010199] pcieport 0000:00:1d.0: AER: Uncorrected (Non-Fatal) error received: 0000:00:1d.0
[  128.010209] pcieport 0000:00:1d.0: PCIe Bus Error: severity=Uncorrected (Non-Fatal), type=Transaction Layer, (Requester ID)
[  128.010210] pcieport 0000:00:1d.0:   device [8086:51b0] error status/mask=00100000/00004000
[  128.010211] pcieport 0000:00:1d.0:    [20] UnsupReq               (First)
[  128.010213] pcieport 0000:00:1d.0: AER:   TLP Header: 34000000 20000052 00000000 00000000
[  128.010268] thunderbolt 0000:22:00.0: AER: can't recover (no error_detected callback)
[  128.010277] xhci_hcd 0000:56:00.0: AER: can't recover (no error_detected callback)
[  128.010286] pcieport 0000:00:1d.0: AER: device recovery failed

$cat /var/log/syslog
systemd-sleep[3653]: System returned from sleep state.
bluetoothd[1272]: Controller resume with wake event 0x0
kernel: [  113.010296] PM: suspend exit
systemd[1]: systemd-suspend.service: Deactivated successfully.
systemd[1]: Finished System Suspend.
systemd[1]: Stopped target Sleep.
systemd[1]: Reached target Suspend.
systemd[1]: Starting NVIDIA system resume actions...
systemd[1]: Stopped target Suspend.
/usr/libexec/gdm-x-session[1675]: (II) systemd-logind: got resume for 226:0
/usr/libexec/gdm-x-session[1675]: (II) AIGLX: Resuming AIGLX clients after VT switch
logger[3743]: Sep 14 21:33:02 suspend: nvidia-resume.service
suspend: nvidia-resume.service
systemd[1]: nvidia-resume.service: Deactivated successfully.
systemd[1]: Finished NVIDIA system resume actions.
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): EDID vendor "LGD", prod id 1706
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): Using hsync ranges from config file
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): Using vrefresh ranges from config file
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): Printing DDC gathered Modelines:
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): Modeline "3840x2400"x0.0  592.56  3840 3888 3920 4000  2400 2403 2409 2469 +hsync -vsync (148.1 kHz eP)
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): EDID vendor "LGD", prod id 1706
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): Using hsync ranges from config file
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): Using vrefresh ranges from config file
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): Printing DDC gathered Modelines:
/usr/libexec/gdm-x-session[1675]: (II) modeset(0): Modeline "3840x2400"x0.0  592.56  3840 3888 3920 4000  2400 2403 2409 2469 +hsync -vsync (148.1 kHz eP)
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-0: disconnected
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-0: 2670.0 MHz maximum pixel clock
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0):
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-1: disconnected
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0):
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-2: disconnected
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0):
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-3: disconnected
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-3: Internal DisplayPort
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-3: 2670.0 MHz maximum pixel clock
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0):
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-4: disconnected
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-4: Internal TMDS
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0): DFP-4: 165.0 MHz maximum pixel clock
/usr/libexec/gdm-x-session[1675]: (--) NVIDIA(GPU-0):
/usr/libexec/gdm-x-session[1675]: (II) NVIDIA(G0): Setting mode "NULL"
2
  • Where comes the 5.15.0-48 kernel from, when the current kernel is 5.15.0-47? Did you enable the proposed repo?
    – Pilot6
    Sep 17 at 8:00
  • I enabled pre-release updates (jammy proposed) to get this kernel. I was hoping a newer kernel would resolve my issue. Ultimately switching the graphics device in the BIOS to discrete resolved my issue. Sep 19 at 20:40

1 Answer 1

0

Enabling "discrete graphics" mode in the BIOS under Config -> Display -> Graphics Device remediated the issue.

1
  • First of all, I want to confirm that this is an issue on the Lenovo Thinkpad X1 Extreme Gen 5. Besides switching to "discrete graphics" mode, the default Ubuntu installation uses the open-source nouveau driver which just does not support the RTX 3080 Ti yet so I had to manually switch to a sufficiently recent version of the proprietary Nvidia driver. According to Nvidia's driver search, at least driver version 510.54 seems to be required but newer versions are available.
    – DrTobbe
    Oct 25 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.