2

Lenovo ThinkPad X270, Ubuntu 20.04, everything worked OK.

Then I installed 22.04.

Now (on adapter) the top panel indicator shows battery at about 70%, not charging. In Power settings: built-in battery at 30%, adapter on, not charging. Swappable battery at 99%, adapter on, not charging.

When I unplug the laptop, top panel indicator tells me the estimated time remaining. In Power settings the built-in battery remains unchanged - 30%, adapter on (green color, lightning bolt), not charging. Swappable battery correctly stops showing the lightning bolt icon and green color.

When I work unplugged, the laptop never shows a low battery warning or in any way reacts to the battery being low. It just turns off out of nowhere. Also it does not wake from suspend when the battery is low. Now I live in constant fear of losing my work and wrecking my batteries (probably already wrecked).

$> sudo tlp-stat -b

--- TLP 1.5.0 --------------------------------------------

+++ Battery Care
Plugin: thinkpad
Supported features: charge thresholds
Driver usage:
* natacpi (thinkpad_acpi) = active (charge thresholds)
* tpacpi-bat (acpi_call)  = inactive (kernel module 'acpi_call' load error)
Parameter value ranges:
* START_CHARGE_THRESH_BAT0/1:  0(off)..96(default)..99
* STOP_CHARGE_THRESH_BAT0/1:   1..100(default)

+++ ThinkPad Battery Status: BAT0 (Main / Internal)
/sys/class/power_supply/BAT0/manufacturer                   = SONY
/sys/class/power_supply/BAT0/model_name                     = 45N1111
/sys/class/power_supply/BAT0/cycle_count                    =    503
/sys/class/power_supply/BAT0/energy_full_design             =  23200 [mWh]
/sys/class/power_supply/BAT0/energy_full                    =  12510 [mWh]
/sys/class/power_supply/BAT0/energy_now                     =   3810 [mWh]
/sys/class/power_supply/BAT0/power_now                      =      0 [mW]
/sys/class/power_supply/BAT0/status                         = Not charging

/sys/class/power_supply/BAT0/charge_control_start_threshold =      0 [%]
/sys/class/power_supply/BAT0/charge_control_end_threshold   =    100 [%]

Charge                                                      =   30.5 [%]
Capacity                                                    =   53.9 [%]

+++ ThinkPad Battery Status: BAT1 (Ultrabay / Slice / Replaceable)
/sys/class/power_supply/BAT1/manufacturer                   = LGC
/sys/class/power_supply/BAT1/model_name                     = 45N1127
/sys/class/power_supply/BAT1/cycle_count                    =    370
/sys/class/power_supply/BAT1/energy_full_design             =  23480 [mWh]
/sys/class/power_supply/BAT1/energy_full                    =  19480 [mWh]
/sys/class/power_supply/BAT1/energy_now                     =  19360 [mWh]
/sys/class/power_supply/BAT1/power_now                      =      0 [mW]
/sys/class/power_supply/BAT1/status                         = Not charging

/sys/class/power_supply/BAT1/charge_control_start_threshold =      0 [%]
/sys/class/power_supply/BAT1/charge_control_end_threshold   =    100 [%]

Charge                                                      =   99.4 [%]
Capacity                                                    =   83.0 [%]

+++ Charge total                                            =   72.4 [%]

UPDATE: sudo tlp fullcharge BAT0 does not start charging.

UPDATE: Tried 20.04 live from USB. Internal battery behavior is identical.

UPDATE: Tried pressing the emergency reset button at the bottom of the laptop, it changed nothing. The builtin battery is shown as connected to adapter but not charging all the time. When the laptop was unplugged yesterday, I actually saw the battery level go down a few percent. When it is connected, the level does not seem to go back up. When external battery and adapter is removed, the laptop does not start (if running, dies immediately).

2
  • Charging is controlled by the embedded controller (EC). The X270 has an emergency reset hole on the bottom. Pressing the button (turn off ThinkPad before) also resets the EC which might solve your problem. support.lenovo.com/us/en/solutions/…
    – linrunner
    Commented Sep 15, 2022 at 13:31
  • @linrunner Thanks for the tip. Sadly it changed nothing. Commented Sep 16, 2022 at 7:53

1 Answer 1

1

So this is quite obviously a hardware problem. It is probably just a strange coincidence that it came up at the same time when I installed the newer Ubuntu version.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .