0

I'm trying to connect an old Cisco sftp client to my sftp server running on Ubuntu 22.04. (I followed this setup)

When the client tries to connect, I get the following error:

Sep 13 16:20:54 backuptest sshd[2294]: Unable to negotiate with X.X.X.X port 45234: no matching host key type found. Their offer: [email protected],[email protected],[email protected],[email protected],ssh-rsa,ssh-dss [preauth]

I have already tried to add a conf file like this one:

HostkeyAlgorithms ssh-dss,ssh-rsa
KexAlgorithms +diffie-hellman-group1-sha1

but now I still get:

Sep 13 16:24:34 backuptest sshd[2311]: Unable to negotiate with X.X.X.X port 45423: no matching cipher found. Their offer: aes256-cbc,3des-cbc [preauth]

How can I fix it?

4
  • Do you know that this old Cisco sftp client can work with Ubuntu 22.04. You never said how old, old is.
    – David
    Sep 14, 2022 at 7:07
  • Hi @David. It's Cisco Call Manager 10.5. The problem is not Ubuntu 22.04 itself, but the ciphers used by sftp Sep 14, 2022 at 7:34
  • If it was me I would be asking Cisco.
    – David
    Sep 14, 2022 at 13:30
  • I see. But Cisco does not provide support on 3rd party sftp server. For those interested in fixing it, see my answer below Sep 15, 2022 at 14:38

1 Answer 1

0

This fixed in my case:

Ciphers +aes128-cbc,aes256-cbc,3des-cbc
KexAlgorithms +diffie-hellman-group14-sha1
HostkeyAlgorithms +ssh-rsa
# If you authenticate using a keypair:
PubkeyAcceptedAlgorithms +ssh-rsa

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .