1

Distributor ID: Ubuntu Description: Ubuntu 22.04.1 LTS Release: 22.04 Codename: jammy

I made the mistake of trying Deepin (DDE) in ubuntu recently. I am almost done getting rid of it's many scraps it left after I uninstalled it. But I still get an error when I boot into xfce (but not gnome).

I did:

    ls -l /var/crash

and found:

root@myusername:/home/darkstarcube1# ls -l /var/crash/
total 12224

-rw-r----- 1 myusername whoopsie 9443663 Sep 11 15:51 _usr_bin_kwin_x11.1000.crash
-rw-r----- 1 myusername whoopsie  653161 Sep 11 15:45 _usr_lib_deepin-turbo_booster-desktop.1000.crash
-rw-r----- 1 gdm           whoopsie  652007 Sep 11 15:45 _usr_lib_deepin-turbo_booster-desktop.127.crash
-rw-r----- 1 myusername whoopsie  873780 Sep 11 15:45 _usr_lib_deepin-turbo_booster-dtkwidget.1000.crash
-rw-r----- 1 gdm           whoopsie  873614 Sep 11 15:45 _usr_lib_deepin-turbo_booster-dtkwidget.127.crash

More deepin junk. I tried to find these processes but nothing was found in /usr/lib that had anything to do with turbo, deepin, or dde. So I guess the user_lib part of those files has nothing to do with where they are located (that would be too easy). I changed my username in the output above to myusername.

That error with kwin_x11 also only started when I installed deepin and was a reason I uninstalled it. DDE wouldn't run without an error related to kwin_x11.

Firstly, how do I get rid of these 5 crash errors?

If they make it easy to install, meta package or not, it should have a tool to completely uninstall it as well. They should know what files will be added and changed where and write a script to reverse and delete all of that mess. In the Windows world, programs that don't have effective uninstall tools are seen as garbage to risky to install in the first place. Shouldn't Linux have a higher standard?

I have successfully removed the grub2 entry, the login screen entry, and several other files that I had to manually select via Synaptic after doing the typical apt-get uninstall of the desktop environment. These extra processes required modifying a few config files and manually looking for and then uninstalling dozens of files. I don't see how an uninstaller would have been hard to build for these processes.

Oddly, a lot of functionality seems broken now. I cannot launch grub-customizer from the icon. It has to be launched by root from a terminal.This is now moot as I am not bothering with grub-customizer. Too buggy. But I also can't launch Synaptic package manager from it's menu icon. I have to use a root terminal for that too. Probably any app that needs admin level permission will now require me to use the terminal.

I get nothing if I try to 'report a problem' when the crash error happens. Usually I would use that to view the details and nail down the issue.

I also had issues updating the software. A typical apt update apt upgrade process always left a dozen or so packages not updated. I could then do apt update and it would successfully update, but it was a new nuisance I wasn't expecting. I think I finally got the last of these files updated.

Of course, I did several things I know of to clean it all up. As sudo:

apt-get clean
apt-get update
apt-get install -f
dpkg -a --configure

and of course,

apt-get autoremove

I also found a page on the toils of removing DDE and did:

ppa:leaeasy/ddenstall ppa-purge

apt remove dde
apt auto-remove dde
apt list --installed | grep dde
apt remove --purge '^dde.*'
apt remove --purge '^deepin.*'
apt autoremove

(all of these commands were as sudo)

It just occurred to me to try

apt list --installed | grep dde

This showed a few more files:

ubuntudde-default-settings/jammy,jammy,now 1.1.9.2ubuntu1 all [installed]
ubuntudde-wallpapers/jammy,now 2022.07.17-1 amd64 [installed]

Yeesh. Now I have to figure out how to remove those as well without breaking anything.

UPDATE: I did use synaptic to uninstall those last two ubuntudde things. Still get that error related to those other four items above.

I tried to search for booster in synaptic and found the package named deepin_turbo_booster. The box next to it was blank, showing it wasn't installed. I selected it anyway and chose to "completely uninstall" to see what would happen. Synaptic said it removed something including config files.

I rebooted,

Logged into my xfce desktop.

Crash error. Still does nothing when I select to report.

tried:

ls -l /var/crash

Nope. Still got the 4 deepin_turbo_booster errors and the kwin error.

Looked for some stuff the harder way:

apt list --installed | grep dde

(found nothing)

apt list --installed | grep booster

(found nothing)

apt list --installed | grep turbo

found:

libjpeg-turbo8/jammy,now 2.1.2-0ubuntu1 amd64 [installed,automatic]


apt list --installed | grep deepin

(found nothing)

Well, that libjpeg file hasn't anything to do with dde so I am leaving it alone. Still get the five errors in xfce. I can load gnome just fine. But I miss xfce. It is my preferred desktop. But I am not dealing with a stupid error every time the desktop loads.

14
  • 1
    Which version of Ubuntu are you using?
    – user68186
    Sep 12, 2022 at 21:07
  • Per lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 22.04.1 LTS Release: 22.04 Codename: jammy
    – user28788
    Sep 12, 2022 at 21:36
  • 1
    Please add the Ubuntu release information in your question and format the pasted output as code using the {_} icon above the edit question window.
    – user68186
    Sep 12, 2022 at 21:39
  • I will try to fix the formatting... I did fix my newly found lsb issue by doing sudo apt-get install lsb-core
    – user28788
    Sep 12, 2022 at 21:43
  • In my experience installing multiple Desktop Environment (DE) in Ubuntu always screws up one thing or the other. As you found out fixing them is not simple. You may want to backup your personal data and reinstall Ubuntu.
    – user68186
    Sep 12, 2022 at 21:46

1 Answer 1

0

You can try repairing the system by reinstalling xfce and depending packages. To do so, first install apt-rdepends package, then run:

apt-rdepends xfce4 | grep -v Depends:

It should display all the dependencies of Xfce. To reinstall them all use something like:

sudo apt install --reinstall $(apt-rdepends xfce4 | grep -v Depends:)

or trim the list if you don't want to reinstall some basic stuff like libc6 etc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .