2

Today afternoon i wanted to download websphere, so i started download and closed the lid and came back after 2 hrs and opened the lid..

I think laptop was running..but when i hit my enter button display is not coming...I had to hard reboot my machine to get the display..

It happened many times..not only in this instance..

I just installed Ubuntu 10.04 ..i did not change anything..Do i need to do anything to enable this feature?

5
  • Have you tried pressing your computers On/Off button when it is 'asleep'? Nov 21 '10 at 14:37
  • After power on from suspend, did you wait a little longer than usual? Wake up from suspend to disk may take minutes on some systems.
    – Takkat
    Nov 21 '10 at 15:05
  • Ya i waited for 5 min..and still display wont turn on..
    – javanoob
    Nov 21 '10 at 15:52
  • Did u try just pressing your computer's On/off button and not an hard reboot.?
    – Vinay
    Nov 21 '10 at 19:00
  • This question should instead be filed as a bug report, thanks! Instructions here. Apr 23 '12 at 22:48
2

You can configure the laptop not to suspend when you close the lid using the power management tools from the menu:

System > Preferences > Power Management

If your laptop has an nVidia graphics card, it may be the open source graphics driver causing the problem. The open source graphics driver has some power management issues on some laptops. Try switching to the closed source drivers with the Hardware drivers tool from the menu:

System > Administration > Additional Drivers

Thank you

1
  • Many thanks, this solution solved my problem on elementary os loki. Oct 24 '18 at 9:12
0

Have you tried coffee?

Seriously though, this would appear to be a bug, see here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/558973 for details.

Im running ubuntu 10.10 and have no problems with sleep functionality, you could perhaps try upgrading to the latest version?

1
  • 2
    Have you tried coffee? I thought u r talking about a software to install to fix this :) ..
    – javanoob
    Nov 21 '10 at 16:16
0

I just selected Blank screen as the option under power management utility for the action when lid is closed..

Now it is working..

-1

I notice something weird. I can resume fine if I enter my password in as though I was getting the login screen.

Apparently the login screen is there but "out of view". Just treat the screen as 'click-through' by assuming the cursor is in the password field. Put the password in and it resumes!

Mind you, I have auto login set but after I suspend I'm getting the login screen anyway though I can't see it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.