27

Since 12.04 I cannot connect to my VPN. my ovpn file is the following

http://email.uoa.gr/help/download/vpn/edunet.ovpn

When I try to import the VPN file i get the following error

The file 'edunet.ovpn' could not be read or does not contain recognized VPN connection information

Error: unknown PPTP file extension.

Is there any way arround this error? I have already installed network-manager-openvpn

36

My problem was that network-manager-openvpn-gnome was not installed, (weird because I though it would get installed automatically after installing network-manager-openvpn). I installed it and everything was fine.

So, to all people having the same problem make sure that

sudo apt-get install openvpn network-manager-openvpn network-manager-openvpn-gnome

after installing, restart the networking service, e.g. by executing

sudo /etc/init.d/networking restart
4

My own experience of successful VPN connection establishing on Ubuntu 14.04

Our admin gave me 3 files to install them into openVPN for Windows 7: *.ovpn, *.crt, *.key

  1. Execute the following commands in your Ubuntu terminal:

    sudo apt-get install openvpn network-manager-openvpn network-manager-openvpn-gnome
    
    sudo apt-get install network-manager-vpnc
    
    sudo /etc/init.d/networking restart
    
  2. Open "Network Connections" window (VPN Connections -> Configure VPN)

  3. Press "ADD" button, click on drop-down menu and pick "Import a saved VPN configuration", press Create button.

  4. In "Select File to import" choose your "*.ovpn" file.

  5. In "Editing ...your *.ovpn file name..." window enter your username and password for vpn. Make sure that a *.crt file appeared in CA Certificate field.

  6. Open "IPv4 Settings" panel and choose "Automatic (VPN) addresses only".

  7. Open "VPN" panel again and click "Advanced" button.

  8. Open "TLS Authentication" panel and make sure your "*.key" appeared in "Key File" field. Press Ok button.

  9. Press "Save" button in "Editing ...your *.ovpn file name..." window.

  10. Your VPN connection should appear in "Network Connections" window.

That's all, I hope it helps. Good luck!

3

I had a similar problem to ECII's. In my case network-manager-vpnc-gnome had to be installed first. To do so I typed in a terminal:

sudo apt-get install network-manager-vpnc
2

When you import be sure that the following fields are populated:

  1. user certificate
  2. CA certificate
  3. privacy key

Your save button will become visible. This worked for me.

  • And then after i installed network-manager-openvpn-gnome I run into the problem of the grayed "Save" button, and I saw that the certificate was missing. I located it and everything worked OK. – ECII May 29 '12 at 7:23
0

If anyone is using KDE as the desktop manager, the right package to be installed may be network-manager-vpnc-kde, if available:

sudo apt-get install network-manager-vpnc-kde

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.