1

New to Linux and askUnbuntu. I am running 22.04 and am trying to use VirtualBox to run Kali. I was able to download, install and create a new VM. When I try to start the machine and before it asks me to select an ISO file, I get this error ...

Failed to open a session for the virtual machine Kali_VM.

Failed to load R0 module /usr/lib/virtualbox/VMMR0.r0: Unable to locate imported symbol 'SUPR0FpuBegin' for module 'VMMR0.r0' (VERR_SYMBOL_NOT_FOUND).

Failed to load VMMR0.r0 (VERR_SYMBOL_NOT_FOUND).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Any ideas? Thank you in advance!

4
  • Which OS are you using for the host system? 🤔
    – matigo
    Commented Sep 8, 2022 at 22:34
  • I am using Ubuntu 22.04 for the host
    – PapaSteve
    Commented Sep 9, 2022 at 18:11
  • problem solved... found solution here forums.virtualbox.org/viewtopic.php?t=106582#
    – PapaSteve
    Commented Sep 9, 2022 at 19:23
  • @PapaSteve - please consider posting the solution as an answer to help others - thanks.
    – Will
    Commented Sep 16, 2022 at 20:34

4 Answers 4

1

VirtualBox 6.1.34 in Ubuntu 22.04 is buggy. Use a newer version of VirtualBox (6.1.36) which you can download from https://www.virtualbox.org/wiki/Download_Old_Builds_6_1.

1

Try this:

sudo apt-get install virtualbox-dkms

it helped me when it stopped launching win7 VM after innocent upgrade vbox from 1.34 to 1.38.

1

Helped me doing downgrade to 6.1.34, history linvx exemple:

sudo dpkg -i virtualbox-6.1_6.1.38-153438Ubuntufocal_amd64.deb
sudo VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-6.1.38.vbox-extpack
sudo dpkg -r virtualbox-6.1
sudo dpkg -i virtualbox-6.1_6.1.34-150636~Ubuntu~eoan_amd64.deb
sudo VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-6.1.34.vbox-extpack
0

Seems Ubuntu updatedVirtualBox to 6.1.38, so a simple apt update and apt upgrade later all worked fine again :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .