1

We recently updated our Ubuntu systems to 22.04.1 at work. These machines are used to run code by multiple users at a time. Since the update, one of the machines no longer allows multiple users to be logged in at a time (i.e. using "switch user"). If we do, we get to the login screen, but end up in a login loop except for the user already logged in. If we use the "log out" option, another user can login, but that would interrupt anything running in the meantime. The other machine works without problems.

One other thing to note is that ever since, when trying to power off the machine in question, it warns that "another user is signed in" and gives the current user as the other user.

I've looked around, but didn't find any solution as of yet. Thanks in advance for any help!

Edit:

  • Sep 8 14:04:24 Morpheus gdm-password]: gkr-pam: unable to locate daemon control file
  • Sep 8 14:04:24 Morpheus gdm-password]: gkr-pam: stashed password to try later in open session
  • Sep 8 14:04:24 Morpheus gdm-password]: pam_unix(gdm-password:session): session opened for user user(uid=1010) by (uid=0)
  • Sep 8 14:04:24 Morpheus systemd-logind[944]: New session 8 of user user.
  • Sep 8 14:04:24 Morpheus systemd: pam_unix(systemd-user:session): session opened for user user(uid=1010) by (uid=0)
  • Sep 8 14:04:24 Morpheus gdm-password]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring
  • Sep 8 14:04:25 Morpheus gnome-keyring-daemon[5127]: The SSH agent was already initialized
  • Sep 8 14:04:25 Morpheus gnome-keyring-daemon[5127]: The PKCS#11 component was already initialized
  • Sep 8 14:04:25 Morpheus gnome-keyring-daemon[5127]: The Secret Service was already initialized
  • Sep 8 14:04:25 Morpheus gdm-password]: pam_unix(gdm-password:session): session closed for user user
  • Sep 8 14:04:25 Morpheus systemd-logind[944]: Session 8 logged out. Waiting for processes to exit.
4
  • I know it's too late, but if you want a working system, don't do a release upgrade. Use the current release as long as it is supported, then do a fresh install of the new one, migrating all data and config. I know it can be a lot of work, but recovering from an upgrade that went wrong can be even more work. So if you want a stable, working system, don't upgrade. There are just too many possible configurations for the upgrade to be guaranteed to work in all cases.
    – raj
    Sep 8, 2022 at 11:14
  • @raj yes. And use 2 or more servers to cycle through as the live server, fallback server and backup server. Where one of these can be used to install and test the new version and 1 rsync to update that one with data from the current one. if mysql datareplication is also an option.
    – Rinzwind
    Sep 8, 2022 at 11:44
  • 1
    Check the IDs of all users. Those need to be different for all users. Check the permissions of the hidden files in /home/*/ for wrong credentials (all need to be either root or owned by the name of the directory above it)
    – Rinzwind
    Sep 8, 2022 at 11:46
  • @Rinzwind All user IDs are unique and all files and directories in /home/*/ are owned by the respective users.
    – Lruij
    Sep 8, 2022 at 12:03

2 Answers 2

0

I figured out what the problem was.

Apparently the Nvidia driver that was installed didn't play nice with 22.04 and the settings for the Updates app were messed up somehow. A manual install of the drivers fixed it!

3
  • Then you should mark this question as closed. Secondly, next time you ask such a question, be more specific about things like 3rd party graphics drivers. You didn't mention that you used them, so nobody guessed that they may be the problem. Sep 8, 2022 at 16:28
  • 1
    Tried to close it, AskUbuntu won't let me for another day. Secondly, if I had been aware of the fact that there was something up with the drivers, I wouldn't have needed to ask for help in the first place.
    – Lruij
    Sep 9, 2022 at 8:39
  • OK, that is fair. It's a major non-default element of the OS though. Something to bear in mind. Sep 10, 2022 at 23:11
0

I ran into the same issue while upgrading a machine from 20.04 to 22.04. This machine also used the proprietary Nvidia driver. After upgrading the Nvidia driver to nvidia-driver-525 and rebooting the system, switching users seems to work again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .