0

I installed ProtonVPN. It worked for a while with Firefox. Then ProtonVPN started to send "not responding" error messages. Though the internet is fully operational on all other devices, Firefox gives me this message:"We can't connect to the server...If you have entered the right address you can: try again later, check your network connection, check that firefox has permission to access the web ( you might be connected behind a Firewall) I have unistalled ProtonVPN.I don't know how to check Firewall settings? Can anyone help?

This has happened to me before on another laptop. ProtonVPN causes a problem with Firefox or visa versa on Ubuntu.

1 Answer 1

1

The issue isn't likely a firewall. If you haven't intentionally used a firewall in Ubuntu, it's probably not set up (it's installed but not automatically turned on).

I found the following solution to this particular problem on another forum for Arch Linux users here.

Proton VPN adds a file that blocks the ability to use the internet the usual, non-VPN way. Uninstalling Proton doesn't automatically delete this file, so it needs to be manually removed. To do so:

  1. open up Ubuntu's terminal app and enter (or copy and paste this command and hit Enter)

     nmcli connection show --active
    
  2. in the info that shows up, look for something that says "pvpn-ipv6leak-protection"

  3. if you see the above in the list, then enter (or copy/paste)...

     nmcli connection delete pvpn-ipv6leak-protection
    

    ...and close the terminal

  4. you may need to restart the computer for the solution to take effect

If "pvpn-ipv6leak-protection" does show up in the list mentioned above but this solution doesn't quite solve the issue, you may then have to...

  1. right-click on the wifi icon in your taskbar and open Configure Network Connections. In the left-hand panel, select whatever your particular wifi is called and click the minus sign below to "remove selected connection"

  2. restart your computer

  3. after rebooting, "regular-click" your wifi icon to bring up the list of available wifi networks, select the one you want to use and enter the password, if you have one (and you should have one!)

5
  • Thank you for reaching out and for all the time you have taken in doing so. I think you are right. The VPN has changed a setting somewhere. I followed your advice. Still not fixed unfortunately...
    – Holly
    Commented Sep 9, 2022 at 18:47
  • 1
    Hey no problem. Have you ever had to use the terminal in Ubuntu? I found a potential fix that I only partially understand (because I haven't used a VPN). Search your programs by typing "terminal" and open whatever the program is called (mine's called Konsole). In the terminal, type "nmcli connection show --active" (with both dashes but without the apostrophes). See if the result shows "pvpn-ipv6leak-protection." If it does, then type "nmcli connection delete pvpn-ipv6leak-protection" (without apostrophes). I'm out of room here so let me know and then I'll show you the next step tomorrow.
    – Royan
    Commented Sep 11, 2022 at 6:37
  • Ryan! You are an answer to my prayers (genuine). High five, low five and every kind of five! I followed your instructions, and...It is fixed! :D God and His Son Jesus Christ are great! I am very thankful that He sent you to me!
    – Holly
    Commented Sep 11, 2022 at 12:57
  • I'm very glad it helped! Non-functional wifi is the worst. I have added this solution as a proper "answer" rather than a comment. If you accept the answer (I think there's some link saying "accept answer" or something), then the next person who comes along with the same question will know this worked. God bless!
    – Royan
    Commented Sep 11, 2022 at 21:57
  • Okay Super! Will do. 😀😃😁
    – Holly
    Commented Sep 12, 2022 at 5:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .