4

i have a Lenovo ThinkPad X1 10th gen. It came with Ubuntu 20.04 preinstalled and the webcam (IPU6 Intel) worked fine, I think because an additional driver was installed by default, but when I upgraded and installed Ubuntu 22.04 the webcam doesn't work anymore. Does anyone have the same problem?

Cheese error:

cheese error

1 Answer 1

4

I'm in the same boat and have done a bunch of research on the issue. There's no official fix today but things do look promising.

A description of the general issue:

A possible, unconfirmed fix:

And Lenovo's updates on their progress for an official fix:

Post back here if you get it fixed and I'll do the same.

4
  • I have the same issue with Thinkpad X1 Carbon Gen 10, Kubuntu 22.04. Tried installing from source and also this askubuntu.com/a/1417193 Now the cam is detected by chrome as "Virtual Camera", but instead of image shows some stipes like No Signal image. As of time writing, this state led to OOM and v4l2-relayd was killed thus reverting me to "No camera found" state.
    – GrozaiL
    Dec 6, 2022 at 16:51
  • Also now I am experiencing this issue mail-archive.com/[email protected]/… EDIT: Problematic v4l2-relayd comes from libcamhal-ipu6ep0 from here ppa:oem-solutions-group/intel-ipu6 So if there are any news about the bugs resolution/workarounds for cameras would be glad to hear
    – GrozaiL
    Dec 6, 2022 at 17:30
  • Is there any update on this? I just bought a new X1 and I am really frustrated that the camera does not work Mar 30, 2023 at 15:39
  • 1
    I finally got it working: askubuntu.com/questions/1461734/… Apr 2, 2023 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .