1

Yesterday, I ran into a problem on my dual-boot system. To give you some context, I hadn't used for some days the laptop, and when I finally decided to get back to work its battery was on zero. I plugged it in and opened it and as I have both Ubuntu 20.04 on a HDD of 1TB and Windows 10 on a SSD of 500Gb, the laptop (HP) by default opened the Windows partition. All fine till now, but I needed to open Ubuntu so I clicked the restart button, but then Windows started an update. I waited for it to finish as the message told not to shut down the PC. However, after the update completed the message "Cleaning Up, Do Not Turn Off Your Computer" appeared. At this point, I don't exactly know why, probably because of not paying attention, I panicked a bit and shut down the PC. As I lately found out here, I probably should not have done this because that process of cleaning was unharmfull and even necessary.

After all of these, I finally entered GRUB and chose to open Ubuntu. The Grub interface looked fine, but after it, some error messages appeared. These errors are not fatal in my view, but I have some trouble in understanding them and I don't know how to correct them. It is the first time I see them. I say they are not fatal because the booting process does not stop and after 30 seconds, at most, Ubuntu starts. From yesterday till now, I rebooted my Ubuntu OS several times and the message log varied, but as I see know it reached some sort of stable state. I would put an image but I don`t have 10 reputation yet. I'm going to copy the log by hand instead:

[0.117946] x86/CPU: SGX disabled by BIOS

[0.300647] platform MSFT0101:00: failed to claim resource 1: [mem 0xfed40000-0Xfed40fff]

[0.300655] acpi MSFT0101:00: platform device creation failed: -16

/dev/sdb1: clean, 276988/1531904 files, 4922273/6103515 blocks

[14.079275] usb 1-5: Failed to query (GET_INFO) UVC control 8 on unit 1: -32(exp. 1).

Ok, so coming back to my initial question, is it something I should be worried about if I let the systems as they are and continue my work? (I should mention probably that Windows seems to work fine). In addition, if anyone can come with any explanation of any of the error messages above I would be very grateful.

When searching the web, I didn't find the exact answer to my problem. It isn't singular for sure. From what I understand, it might be that I interrupted that process of cleaning after the update of Windows and some fragments or temporary files remained possibly on the HDD where Ubuntu stands. The ultimate solution would be to format the HDD and reinstall Ubuntu but it might be quite a hassle as Ubuntu seems to work fine and properly aside these 4 error messages.

I also tried the "fsck" command. However, I didn't manage to apply it on /dev/sdb1 because the partition was mounted and on use. I read about entering recovery mode, which I did, but somehow I still didn't manage to solve the issue. I inspired myself from here.

Given Jos request, I'm going to add here the output of "df" command:

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sdb1 22980836 18297544 3446208 85% /
/dev/sdb2 936350412 39407764 849308936 5% /home
/dev/sda1 98304 30890 67414 32% /boot/efi
13
  • I think it is unlikely that there is any real damage to either partition, but in order better to understand your issue, please state in your question which filesystem contains what, i.e. basically the output of the df command.
    – Jos
    Sep 6, 2022 at 17:14
  • I'm going to do this in a short time Sep 6, 2022 at 17:21
  • Hey, I've just managed to show the info shown by "df" command in a more suitable format I think. Is it enough? The command showed more lines. I put only these 3 lines because I am preety sure that sdb is the HDD where Ubuntu stays and sda is the SSD where Windows stays. However, I'm not really sure how I should interpret this piece of information. Any further comments will be of help. Sep 6, 2022 at 17:54
  • 1
    No /dev/sda1 is certainly not the Windows partition, it is the EFI partition. There must be another partition containing Windows. Anyway the Ubuntu partitions are clean. There is no need to fsck them. A Windows partition should be checked and repaired using Windows tools. The error messages you mention can each be googled and do not turn up anything serious. Only the last one may indicate that your webcam (or some such device) doesn't work. If so, please post a separate question.
    – Jos
    Sep 6, 2022 at 18:25
  • 1
    (1) I don't believe the Windows system even can access the Ubuntu partitions, and certainly not during a systems update. (2) A quick fsck is done at every Ubuntu boot for the filesystems to be mounted; you posted the outcome of the fsck of / yourself. If there were any inconsistencies, your boot would pause until you ran fsck manually. So yes, I am pretty confident that everything is OK on the Ubuntu side.
    – Jos
    Sep 6, 2022 at 18:43

0

You must log in to answer this question.

Browse other questions tagged .