16

I downloaded Ubuntu 12.04 desktop and I am trying to create a bootable USB drive using the universal USB installer.

However, I keep getting the message:

An error(1) occurred while executing syslinux. Your USB drive won’t be bootable.

I have formatted the USB using FAT32 (both quick and complete format) and even tried only FAT. The error still appears. I have also turned off all firewall but it does not make a difference.

Why is this happening?

4
  • No partition on the usb drive. Its just 1 gb fat32 formatted. Running windows 7
    – Sab
    Commented May 27, 2012 at 4:49
  • Are there any other messages in the Windows System Event log at the same time which might provide more information about what the actual error is? (To view system events, open the Windows Event Viewer.) Commented May 27, 2012 at 5:03
  • syslinux has changed its interface. It used to be syslinux <device> It is now syslinux install <device> Unetbootin needs to update its call. See man syslinx and man syslinux-legacy. Commented Jul 18, 2018 at 11:52
  • I also had this problem and none of the solution worked for me except one: disabling windows security before making usb drive, then enabling again after im done, as per @CJBS 's 2019 answer below.
    – Leo
    Commented Jul 4, 2021 at 12:19

9 Answers 9

24

I also used the universal usb installer, and also got that problem.

Try reformat the drive to NTFS and try again. It should work.

9
  • 1
    But i thought the drive should be fat32 formatted to boot from
    – Sab
    Commented May 27, 2012 at 3:34
  • I know! Everyone says that (look at the question above) but NTFS worked for me while FAT32 didn't. Commented May 27, 2012 at 3:36
  • 3
    That didnt work for me. Probably there is some other issue which i am unable to figure .
    – Sab
    Commented May 27, 2012 at 3:55
  • 3
    This worked for me 7/21/12. I formated to NTFS (contrary to what everyone else was saying) and it worked fine.
    – EGHDK
    Commented Jul 21, 2012 at 8:32
  • 1
    Just worked for me
    – DanH
    Commented Nov 9, 2013 at 3:46
5

I've had the same problem with Ubuntu 12.04 desktop 64bits. I tried 2 times, same error: Syslinux shows a warning, closes and say "Won't be bootable".

So, I formatted the USB stick BEFORE opening universal USB installer, and NOT checked the "format drive" option (checkbox) and it worked just fine.

3

Download Unetbootin for Windows and try that:

http://unetbootin.sourceforge.net/

Before going ahead and making the Bootable USB, it's always a good idea to check the md5sum of the iso that you downloaded:

https://help.ubuntu.com/community/HowToMD5SUM#MD5SUM_on_Windows

This can save you a lot of grief later if it turns out the download was corrupt

Chris

Edit: @emersonhsieh, I think the LiveUSB must be formatted FAT to be able to boot off it.

@ Chris Mine had fat32 but it didn't work. after I reformatted it to ntfs it didn't have the error message.

@eversonhsieh: I have come across situations where the partition table put on the USB stick by the manufacturer causes some problems. The solution is to delete the partition table completely, remake it, and re-format FAT. Chris

I'm adding this as another edit, because my comment below seems to get hidden by a "show more" link. I think it's important enough to put it here in clear as it's caused a problem for quite a few people, myself included:

Ok, I've just verified this problem with Unetbootin and Ubuntu Startup disk creator on a Verbatim 2Gb drive. The problem is the partition table that the manufacturers put on the devices. Perhaps it's not marked bootable, or has something non-standard in there. The solution is to remove the partition table on the device, and remake a new partition table. You can then create a new partition and format it FAT32 and it will work. Chris

8
  • Unfortunately unetbootin does not support ubuntu 12.04 desktop version.The checksum appears to be the same.
    – Sab
    Commented May 27, 2012 at 3:15
  • @user65646 I know! Everyone says that but NTFS worked for me while FAT32 didn't. Commented May 27, 2012 at 3:39
  • Unetbootin does not really care what release it is. Just select the radio button for "Diskimage" and point Unetbootin at the ISO on your hard drive. (12.04 may not be in the download section "Distribution" yet as it hasn't been updated. Commented May 27, 2012 at 3:41
  • Okay. Let me try that out
    – Sab
    Commented May 27, 2012 at 4:09
  • I've used FAT32 with Unetbootin a number of times, for various bootable .iso images, and it has always worked for me. Commented May 27, 2012 at 4:24
2

I resolved this problem. I tried format stick from FAT32 to NTFS - without results. I tried to format stick BEFORE running the Installer - without results. Then I did SLOW, LONG format of my USB stick using the system's Windows format (right click of mouse on the icon of USB stick and not-marked "Fast format"). Good luck ! :-)

1

Here's my experience after following some of the top rated answers on this thread.

  1. Formatting with NTFS using Windows built in format utility got rid of syslinux error but I could never boot from the pendrive.
  2. Formatting with exFAT be it quick or thorough didnt solve the problem and syslinux error persisted.

  3. Universal USB Installer has a setting to format fat32 as highlighted in the image:

    enter image description here

This setting worked perfectly fine, the pen drive was formatted by this tool, installer was copied and I could boot from the pen drive.

2
  • +1 for trying out existing answers and figuring out one that still works today. Also, good screenshot to show what options were being selected to create the bootable USB in Windows.
    – user37165
    Commented Jan 7, 2016 at 8:59
  • New versions of USB installer have removed this option however. Why???
    – Calydon
    Commented Jan 28, 2020 at 3:02
1

Disable Windows Ransomware Protection

Windows Ransomware Protection was preventing syslinx from working correctly. Actually, it displayed a pop-up notification indicating that it was prevented from working.

After disabling Windows Ransomware Protection, I was able to write an Ubuntu image.

How to Disable Windows Ransomware Protection?

Start ➜ (type) Settings ➜ Windows Security ➜ Virus & threat protection ➜ Ransomware protection ➜ Manage ransomware protection ➜ Controlled folder access ➜ set OFF

This can be reenabled after the USB image creation

1
  • This is the only thing that solved it for me.
    – Leo
    Commented Jul 4, 2021 at 12:18
1

FAT32 has a maximum partition size of 32GB. If you're using a newer flash drive, it's likely greater than 32GB - so you will have problems.

Delete all the partitions and the volume, then create a new volume that is 32GB or less in size.

Now the ISO -> USB program can re-format as FAT32 successfully.

0

I was having the same problem of "SYSLINX ERROR" Format your pendrive using NTFS format and then load your ios (Note: Again Don't format pendriver with bootable software ok it will not work if you format it again with bootable software). it will work fine.

0

My experience is to make sure no GPT used in boot as mentioned in the requirements of the UUI.

e.g., re-run rufus to make sure MBR boot is used.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .