7

I just updated my kernel to 5.15.0-47-generic #51-Ubuntu SMP Thu Aug 11 07:51:15 UTC 2022 x86_64 and while in general the system seems to behave fine a VM running Windows on VirtualBox 6.1.34-dfsg-3~ubuntu1.22.04.1 starts to misbehave reproducible. One visible effect is that Chrome in the Windows VM crashes regularly.

When I reboot the machine into the 5.15.0-46 kernel version the problem disappears. When I then reboot the machine into the 5.15.0-47 kernel the problem is back again.

Here are some further system details:

Ubuntu 22.04.1 LTS x86_64
HP EliteDesk 805 G6 Desktop Mini PC
AMD Ryzen 5 PRO 4650G with Radeon Graphics (12) @ 4.308GHz

Any ideas? Is there some known issue already out there?

4
  • try rebuilding the dkms. then if it still doesn't work then try using some light weight browser like midori
    – Rishon JR
    Sep 1 at 15:52
  • This seems also relevant: bugs.debian.org/cgi-bin/bugreport.cgi?bug=1012627 This issue is already discussed in the Linux Kernel and Virtual Box Bug tracker since middle of May. It is related to Linux Kernel commit 6e8ec2552c7d which fixes security vulnerabilities. Patches for this issue are available since around 2 weeks. This are patches for latest stable upstream release '6.1.34'.
    – cs224
    Sep 4 at 7:59
  • 1
    Here is the link to the launchpad bug report: bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1988473
    – cs224
    Sep 4 at 8:01
  • I have the same problem - when I start MS Teams in a Windows VM, it crashes latest 2 mins afterwards. I booted the previous 5.15.0-46 kernel and it's rock stable as it used to be.
    – nagelp
    Sep 8 at 13:24

5 Answers 5

7

Updating to the latest VirtualBox version (6.1.34 -> 6.1.38 r153438) solved the problem for me on Xubuntu as described in https://www.linuxcapable.com/how-to-install-virtualbox-6-1-on-ubuntu-22-04-lts/ or https://www.virtualbox.org/wiki/Linux_Downloads - the latest Ubuntu kernel 5.15.0-47 does not have to be removed.

5
  • 1
    It seems that the problem is with VirtualBox and not with the kernel. I followed your advice and now it works. Important was to completely remove the previous virtualbox and its kernel modules, because otherwise after the new install you may end up with a mix of kernel modules and the wrong one may be loaded (apt purge virtualbox).
    – cs224
    Sep 4 at 8:43
  • Follow the instructions here: forums.virtualbox.org/viewtopic.php?f=1&t=106582#p521063 if you end up with a "Failed to load R0 module /usr/lib/virtualbox/VMMR0.r0" or similar error. In addition I had to manually install the extension pack (see here: askubuntu.com/a/734926/666748). After that it worked as expected.
    – cs224
    Sep 4 at 8:43
  • I was getting VMMR0.r0 error so I had to remove virtualbox-dkms and reinstall 6.1.38, if anyone gets that error
    – Cagri
    Sep 6 at 14:21
  • installing 6.1.38 appears to have resolved Windos 10 guest crashing problem. Thanks.
    – LXJ
    Sep 9 at 11:33
  • virtualbox/jammy-updates 6.1.38-dfsg-3~ubuntu1.22.04.1 is now released. Sep 17 at 10:13
2

Yes, I encountered similar issue. Under kernel 5.15.0-47 virtualbox guest (Windows) started to crash and reboot quite frequently.

Finally rebooted to older 5.15.0-46 and no problems any more.

1
  • That worked for me too - and is the least amount of messing about required as the previous kernel 5.15.0-46 is likely still installed - just select it at boot time. Sep 9 at 16:18
2

Yes, same here, except that I am using a Kubuntu guest on a Kubuntu host. I lost almost a day trying all kinds of things, trying to find a reliable pattern to reproduce it or browser-settings to prevent it. Until I tried booting the host (not the guest) with the previous kernel version and all problems disappeared.

I temporarily did the following:

apt purge linix-image-5.15.0-47-generic linux-image-unsigned-5.15.0-47-generic 

on the host. This left me with the -46 kernel as the default boot option, which is still installed.

for some reason the -unsigned package keeps popping up unless you purge it in the same command alongside with the normal linux-image.

This will then also automatically uninstall the meta package linux-image-generic and this should prevent any further kernel upgrades, and this way I also don't have to mess with grub defaults and I can be sure it won't eventually automatically purge the last working kernel. I will leave it that way until I know the problem is solved and then install the meta package again.

It was not only Chrome that was crashing, it also affected Firefox (that one crashed even more often than Chrome), also other apps were crashing, for example Telegram, and even the entire Plasma shell has crashed once or twice already. Disabling compositing or even using a different window manager also had no effect, also disabling 3D acceleration of the VM did not help.

There are already bug reports popping up that I would bet are related, like this for example: https://www.mail-archive.com/kernel-packages@lists.launchpad.net/msg486212.html

1
0

I have been experiencing this issue for a few days.

Kernal version:5.15.0-47-generic

Virtualbox version:6.1.34

The problem was that VirtualBox crashed immediately after launching Chrome or Edge

updating to Virtualbox 6.1.36 solved the issue

0

On Thursday (01.09.22) I started experiencing similar problems as the one described by the OP with my VirtualBox 6.1.34 in all my guest OS (Windows, Ubuntu2016, Ubuntu 2018 and CentOS 8). These VMs are running in my Ubuntu 2022.04 LTS Host OS (Lenovo Thinkpad T14S). My current linux kernel is:

Linux lautaro 5.15.0-47-generic #51-Ubuntu SMP Thu Aug 11 07:51:15 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

The problem is clearly reproducible with two actions: either opening Google Chrome or dragging the VM screen with the mouse to Full Screen. After wasting 2 days of trying several things including updating Virtualbox to 6.1.36 (it did not solve anything), updating guest-additions in all VMs, re-signing VirtualBox Kernel modules, tracking internal /var/crash reports of my VMs and still not being able to solve this issue I detected today that at the very same day the problems started there was a kernel upgrade as shown in /var/log/apt/history.log in the following line:

Upgrade: linux-image-generic-hwe-22.04:amd64 (5.15.0.46.46, 5.15.0.47.47), linux-headers-generic-hwe-22.04:amd64 (5.15.0.46.46, 5.15.0.47.47), linux-generic-hwe-22.04:amd64 (5.15.0.46.46, 5.15.0.47.47)

(Full command output):

jaogor@lautaro:/var/log$ grep -B 4 -A 4  -nH $(uname -r) apt/history.log*    
apt/history.log-2-Start-Date: 2022-09-01  10:47:49
apt/history.log-3-Commandline: /usr/bin/unattended-upgrade
apt/history.log:4:Install: linux-image-5.15.0-47-generic:amd64 (5.15.0-47.51, automatic), linux-headers-5.15.0-47-generic:amd64 (5.15.0-47.51, automatic), linux-modules-5.15.0-47-generic:amd64 (5.15.0-47.51, automatic), linux-headers-5.15.0-47:amd64 (5.15.0-47.51, automatic), linux-modules-extra-5.15.0-47-generic:amd64 (5.15.0-47.51, automatic)
apt/history.log-5-Upgrade: linux-image-generic-hwe-22.04:amd64 (5.15.0.46.46, 5.15.0.47.47), linux-headers-generic-hwe-22.04:amd64 (5.15.0.46.46, 5.15.0.47.47), linux-generic-hwe-22.04:amd64 (5.15.0.46.46, 5.15.0.47.47)
apt/history.log-6-End-Date: 2022-09-01  10:48:16

Now I will try the actions suggested in this post (upgrade to Virtualbox 6.1.38) or downgrade my kernel version and post the results.

2
  • 1
    Yesterday I finally updated to Virtualbox Version 6.1.38 r153438 and my problems went away. This was a very painful bug in virtualbox. does anyone knows where to write to vbox developers? Sep 8 at 9:36
  • By the way, after I updated to version 65.1.38 I had to solve the problem described in the comment of cs224 "Failed to load R0 module /usr/lib/virtualbox/VMMR0.r0", so I had to rmmod the previous version of vboxdrv (which was version 6.1.34), reboot and then insmod the vboxdrv version 6.1.38 (located in /lib/modules/5.15.0-47-generic/misc/vboxdrv.ko) Sep 8 at 9:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.